Applying Windows Imaging and Configuration Designer profile fails and causes boot loops

New Contributor

What I am trying to do is make a profile in Windows Imaging and Configuration Designer that does the following.

Domain join
Local admin
Rename the computer
Skip Out of box/Turn off Cortana
Enrol into our MDM (airwatch)
Upgrade Windows Edition to Education edition

 

I have four machines (1 HP ProBook 4340s and 3 x Dell Latitude 3380) with the ProBook running Windows 10 Education 1607 Build 14393 and the Latitude's running Windows 10 Education 21H1 Build 19043.1052

 

When I use the profile on the ProBook everything works as expected other than enrol into our MDM (working on figuring that part out) but when I use the exact same USB on the Latitudes Windows will upgrade the Windows Edition, reboot, creates local admin account and then everything else will display a "failed" message on screen next to the task (domain join, rename and enrol into MDM). After it has failed it will say "your computer will reboot in less than one minute", it will reboot and then just keep repeating "your computer will reboot in less than one minute".

 

I have tried removing the upgrade edition part and rebuilding the package to another freshly formatted USB and still get the same boot loop.

 

<?xml version="1.0" encoding="utf-8"?>
<WindowsCustomizations>
  <PackageConfig xmlns="urn:schemas-Microsoft-com:Windows-ICD-Package-Config.v1.0">
    <ID>{927a49e6-9d78-4bd8-8aa9-894a416ee45b}</ID>
    <Name>Project_1</Name>
    <Version>1.2</Version>
    <OwnerType>ITAdmin</OwnerType>
    <Rank>0</Rank>
    <Notes />
  </PackageConfig>
  <Settings xmlns="urn:schemas-microsoft-com:windows-provisioning">
    <Customizations>
      <Common>
        <Accounts>
          <ComputerAccount>
            <Account>domain\ADJoin</Account>
            <AccountOU>OU=2022,etc,etc</AccountOU>
            <ComputerName>code-%SERIAL%</ComputerName>
            <DomainName>domain.name</DomainName>
            <Password>password</Password>
          </ComputerAccount>
          <Users>
            <User UserName="local admin" Name="local admin">
              <Password>local password</Password>
              <UserGroup>Administrators</UserGroup>
            </User>
          </Users>
        </Accounts>
        <OOBE>
          <Desktop>
            <EnableCortanaVoice>False</EnableCortanaVoice>
            <HideOobe>True</HideOobe>
          </Desktop>
        </OOBE>
        <Workplace>
          <Enrollments>
            <UPN UPN="account@airwatch" Name="account@airwatch">
              <AuthPolicy>OnPremise</AuthPolicy>
              <DiscoveryServiceFullUrl>url here</DiscoveryServiceFullUrl>
              <EnrollmentServiceFullUrl>url here</EnrollmentServiceFullUrl>
              <PolicyServiceFullUrl>url here</PolicyServiceFullUrl>
              <Secret>password</Secret>
            </UPN>
          </Enrollments>
        </Workplace>
      </Common>
    </Customizations>
  </Settings>
</WindowsCustomizations>
0 Replies
www.000webhost.com