DFS Replication Service dies with Error 1067: The process terminated unexpectedly.

Visitor

Can you help me to fix this????

 

I upgraded a Client's Server from Windows 2012 non-R2 to Windows 2019 on the old Dell server (T320). Once we received a replacement Dell server (T440), I installed Windows 2019 on it. Then, I added to the domain, promoted it to a Domain Controller (replicating AD & SYSVOL), copied all of the corporate shares to it. Everything was working fine.

After about 30 days of normal operation, I demoted the old server (Dell T320) so that I could rebuild it to use as an archive file server. I also uninstalled the Active Directory from it before I shut it down for the rebuild. I rebuilt the server from scratch - updating the firmwares & BIOS, reconfiguring the RAID disks from RAID 6 to RAID 5 (with hot-spare), re-installed Windows 2019, and updated the drivers. Everything went fine until I decided to add it as a DC (Domain Controller). After I promoted it to a DC, I saw the event 4612 message "The DFS Replication service initialized SYSVOL at local path C:\Windows\SYSVOL\domain and is waiting to perform initial replication."

 

I found that the rebuilt server (SVR01 - Dell T320) DFSR could not communicate with DSFR on the new server (SVR02 - Dell T440). I tried to start the DFS Replication Service. It just crashes and displays a box that says, "Error 1067: The process terminated unexpectedly."

 

I have been searching the internet for several days trying to fix this. The suggestions I've tried are:

How to force an authoritative and non-authoritative synchronization for DFSR-replicated SYSVOL:

https://support.microsoft.com/en-us/help/2218556/how-to-force-an-authoritative-and-non-authoritative...

 

DFS Replication: How to troubleshoot missing SYSVOL and Netlogon shares:

https://support.microsoft.com/en-us/help/2958414/dfs-replication-how-to-troubleshoot-missing-sysvol-...

 

And, others. Bottom-line: I don't believe these are the answers because the DFS Replication Service won't start. I feel they can be used once I can get the service to start. I've looked at Debug log files but it seem to help me. I'll include them below:

 

* DFSR Log Sequence:1 Index:54 Computer:MSSVR02 TimeZone:Eastern Daylight Time (GMT-04:00) (TzId>Eastern Standard Time<dIzT) Build:[Jan 01 2016 08:00:00 built by: WinBuild (FRE)]
* Configuration logLevel:4 maxEntryCount:200000 maxFileCount:1000 logPath:\\.\C:\WINDOWS\debug\
20200901 22:30:19.670 5400 EVNT 1195 EventLog::Report Logging eventId:1314 parameterCount:1
20200901 22:30:19.670 5400 EVNT 1215 EventLog::Report eventId:1314 parameter1:C:\WINDOWS\debug
20200901 22:30:19.670 5400 FSVC 1059 [ERROR] FrsService::RunAsService Failed to Run Service:
+ [Error:2(0x2) MainInitializeGlobalsAfterServiceStarted main.cpp:518 5400 W The system cannot find the file specified.]
+ [Error:2(0x2) SetFilesNotToBackupValue contentsetmanager.cpp:10294 5400 W The system cannot find the file specified.]
20200901 22:30:19.670 5400 EVNT 1195 EventLog::Report Logging eventId:1008 parameterCount:0
20200901 22:30:19.670 5400 SCNT 623 ServiceControl::SetFinalState Current state:[Service Running], moving to:[Service Stopped]
20200901 22:30:19.670 5400 FSVC 2354 [ERROR] FrsService::ServiceMain Error:
+ [Error:2(0x2) FrsService::RunAsService frsservice.cpp:1074 5400 W The system cannot find the file specified.]
+ [Error:2(0x2) MainInitializeGlobalsAfterServiceStarted main.cpp:518 5400 W The system cannot find the file specified.]
+ [Error:2(0x2) SetFilesNotToBackupValue contentsetmanager.cpp:10294 5400 W The system cannot find the file specified.]
20200901 22:30:19.670 3788 MAIN 844 main Service Exiting Successfully

 

Questions I have:

  1. Why does the DFSR Log have "FRS" in it? I thought FRS was depreciated.
  2. When I start DFSR why does it try to run the FRS Service?

Note: The initial server was 2012 (non-R2) for this client. So, they've never used FRS as far as I am aware.

 

Thanks

 

 

1 Reply

I'm having a DFSR issue with the same debug log you have. Did you find a solution to this?

www.000webhost.com