Hello World Web app installed in Teams: 'Unable to reach app'

Contributor

Hi,

I am trying to use the HelloWorld Web app (HW) from TEAMS application, but 'Unable to reach app' message appears.

 

I have my HW compiled (Microsoft.Teams.Samples.HelloWorld in Visual Studio 2017) running locally (browser opens in http://localhost:3333/)


And with ngrok I can access remotelly (https://5d4c6462.ngrok.io)
         ngrok http 3333 -host-header=localhost:3333


This HW client generates a .zip with 2 .png files and the manifest.json file

Then in my TEAMS app (left panel) I go to Apps-'Upload a custom app', browse and get that .zip. My HW is visible for my user


In 'Teams' tab, I select a Team (MyTeam) and in 'Manage Team'-Apps, I install HW app ('More apps' button), but do nothing with 'Bot'/'Tab' and 'Messaging' options (all of them have a 'Set up' button that seems to do nothing)

 

After that, in MyTeam I can see the HW app when I write @hello, and my commands from composeExtensions (manifest) are available

But when I enter a text, 'Unable to reach app' is displayed

 

I supponse my problem is in the manifest file, but I don't know where... Anything related with an ID?

 

In my Visual project, 'Assembly Info' I have a GUID value: "f543a88..."

I have used this value in the manifest, for 'id', and for 'botId' in 'bots' and 'composeExtensions'
Besides, I used 'https://5d4c6462.ngrok.io' in the urls
The rest of the values in the manifest file are the ones by default

 

Here is my manifest text:


"$schema": "https://statics.teams.microsoft.com/sdk/v1.0/manifest/MicrosoftTeams.schema.json",
"manifestVersion": "1.3",
"version": "1.0.0",
"id": "f543a885-72b3-49b1-93c5-b932bf356d78",
"packageName": "com.contoso.helloworld",
"developer": {
"name": "Contoso2",
"websiteUrl": "https://www.microsoft.com",
"privacyUrl": "https://www.microsoft.com/privacy",
"termsOfUseUrl": "https://www.microsoft.com/termsofuse"
},
"name": {
"short": "Hello World",
"full": "Hello World App"
},
"description": {
"short": "Hello World App for Microsoft Teams",
"full": "This sample app provides a very simple app. You can extend this to add more content and capabilities."
},
"icons": {
"outline": "contoso20x20.png",
"color": "contoso96x96.png"
},
"accentColor": "#60A18E",
"staticTabs": [
{
"entityId": "com.contoso.helloworld.hellotab",
"name": "Hello Tab",
"contentUrl": "https://5d4c6462.ngrok.io/hello",
"scopes": [
"personal"
]
}
],
"configurableTabs": [
{
"configurationUrl": "https://5d4c6462.ngrok.io/configure",
"canUpdateConfiguration": true,
"scopes": [
"team"
]
}
],
"bots": [
{
"botId": "f543a885-72b3-49b1-93c5-b932bf356d78",
"needsChannelSelector": false,
"isNotificationOnly": false,
"scopes": [
"team",
"personal"
]
}
],
"composeExtensions": [
{
"botId": "f543a885-72b3-49b1-93c5-b932bf356d78",
"commands": [
{
"id": "getRandomText",
"description": "Gets some random text and images that you can insert in messages for fun.",
"title": "Get some random text for funnn",
"initialRun": true,
"parameters": [
{
"name": "cardTitle",
"description": "Card title to use",
"title": "Card title"
}
]
},
{
"id": "getRandomText 2",
"description": "Gets some random text and images that you can insert in messages for fun 2.",
"title": "Get some random text for fun 2",
"initialRun": true,
"parameters": [
{
"name": "cardTitle 2",
"description": "Card title to use 2",
"title": "Card title 2"
}
]
}
]
}
],
"permissions": [],
"validDomains": []
}

Any help?

4 Replies

@diegoSpace we don't use TechCommunity for developer questions very much (please use Stack Overflow with the tag "microsoft-teams" but since I happened to see this...

Your messaging endpoint for your bot registration (either on bots.botframework.com or on Azure) should be https://5d4c6462.ngrok.io/api/messages (no trailing slash). Is it?

@Bill Bliss Thanks for your response. I put the message in Stack Overflow, where I added 2 additional doubts... But since you read it here... I can not find where I must add 'https://5d4c6462.ngrok.io/api/messages' as 'messaging endpoint', is it not in the manifest then?

 

Once I had my zip I added to TEAMS application, but i did nothing in Azure. I suppose just with that TEAMS will not be able to find my application, it does not know the 'messaging endpoint' to connect to, correct? How can I do that?

 

Would you prefer my response in Stack Overflow?

 

I really thank you,

Diego

@diegoSpace Please see my answer on the StackOverflow question. Let's use that post for further discussions.

www.000webhost.com