Conditional formula to show/hide columns: works for new items, error in edit view

%3CLINGO-SUB%20id%3D%22lingo-sub-2502153%22%20slang%3D%22en-US%22%3EConditional%20formula%20to%20show%2Fhide%20columns%3A%20works%20for%20new%20items%2C%20error%20in%20edit%20view%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2502153%22%20slang%3D%22en-US%22%3E%3CP%3EI%20have%20this%20problem%20only%20in%20one%20list%20and%20I%20don't%20know%20why.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20have%20create%20a%20list%20with%20many%20column.%20Most%20of%20the%20column%20should%20only%20be%20visible%20if%20a%20checkbox%20is%20selected.%3C%2FP%3E%3CP%3ESo%20I%20used%3A%3C%2FP%3E%3CPRE%20class%3D%22lia-code-sample%20language-applescript%22%3E%3CCODE%3E%3Dif(%5B%24HAT%5D%20%3D%3D%20true%2C%20'true'%2C%20'false')%3C%2FCODE%3E%3C%2FPRE%3E%3CP%3EHAT%20is%20the%20name%20of%20the%20yes%2Fno-checkbox%20field.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EIf%20I%20create%20a%20new%20item%20in%20the%20list%2C%20everything%20works%20as%20expected%3A%20see%20Screenshot%20%22NewItem%22.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EBut%20if%20I%20want%20to%20edit%20an%20item%2C%20I%20get%20only%20a%20blank%20screen%20(no%20fields%20at%20all%20are%20visible)%20and%20I%20also%20cannot%20modify%20conditional%20formulas%20(menu%20does%20not%20open)%3A%20see%20screenshot%20%22EditItem%22.%26nbsp%3B%3C%2FP%3E%3CP%3E%3CBR%20%2F%3EIf%20I%20don't%20maintain%20a%20conditional%20formula%2C%20editing%20a%20item%20works%20without%20a%20problem.%20If%20I%20now%20try%20to%20maintain%20a%20conditional%20formula%20for%20the%20same%20column%20while%20in%20edit-item%20mode%2C%20I%20cannot%20save%20the%20formula.%20The%20%22save%22%20button%20don't%20react.%20No%20error%20message%20appear%3A%20see%20screenshot%20%22EditItem_CreateConditionalFormula%22.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20also%20already%20tried%20to%20recreate%20this%20list%20via%20saving%20a%20template%20and%20recreate%20it%2C%20but%20the%20error%20still%20appears.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EDoes%20anyone%20has%20an%20idea%3F%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThanks%20in%20advance%2C%3C%2FP%3E%3CP%3EMax%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-2502153%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EMicrosoft%20Lists%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E
Occasional Contributor

I have this problem only in one list and I don't know why.

 

I have create a list with many column. Most of the column should only be visible if a checkbox is selected.

So I used:

=if([$HAT] == true, 'true', 'false')

HAT is the name of the yes/no-checkbox field.

 

If I create a new item in the list, everything works as expected: see Screenshot "NewItem".

 

But if I want to edit an item, I get only a blank screen (no fields at all are visible) and I also cannot modify conditional formulas (menu does not open): see screenshot "EditItem". 


If I don't maintain a conditional formula, editing a item works without a problem. If I now try to maintain a conditional formula for the same column while in edit-item mode, I cannot save the formula. The "save" button don't react. No error message appear: see screenshot "EditItem_CreateConditionalFormula".

 

I also already tried to recreate this list via saving a template and recreate it, but the error still appears.

 

Does anyone has an idea?

 

Thanks in advance,

Max

 

0 Replies
www.000webhost.com