Group by view not showing all groups

%3CLINGO-SUB%20id%3D%22lingo-sub-482861%22%20slang%3D%22en-US%22%3EGroup%20by%20view%20not%20showing%20all%20groups%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-482861%22%20slang%3D%22en-US%22%3E%3CP%3EHello%2C%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20have%20a%20document%20library%20with%20multiple%20tags.%20One%20of%20the%20fields%20is%20a%20dropdown%20with%203%20items.%20When%20I%20do%20a%20'group%20by'%20using%20the%20dropdown%20field%20I%20can%20only%20see%20groups%20for%202%20items.%20The%203rd%20one%20is%20just%20invisible.%20I%20have%20documents%20tagged%20to%20all%20three%20options.%20So%20all%20the%203%20tags%20are%20in%20use.%20When%20I%20ungroup%20them%20they%20are%20all%20visible.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EAny%20help%20will%20be%20appreciated.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-482861%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EGroupBy%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3Elibraries%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3ESharepointOnline%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1934343%22%20slang%3D%22en-US%22%3ERe%3A%20Group%20by%20view%20not%20showing%20all%20groups%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1934343%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F327566%22%20target%3D%22_blank%22%3E%40dipand%3C%2FA%3E%3C%2FP%3E%3CP%3Edid%20you%20ever%20figure%20this%20out%3F%26nbsp%3B%20We%20recently%20noticed%2C%20with%20one%20of%20our%20SharePoint%20Online%20lists%20using%20the%20modern%20experience%2C%20that%20when%20you%20initially%20have%20the%20default%20view%20as%20a%20group%20by%20view%2C%20some%20of%20the%20list%20items%20won't%20show%20up%20in%20one%20or%20more%20of%20the%20groups%2C%20but%20then%20changing%20the%20view%20to%20All%20Items%20and%20then%20back%20to%20the%20group%20by%20view%20shows%20them%20all.%26nbsp%3B%20And%20then%20you%20appear%20to%20be%20fine%20from%20that%20point%20on.%26nbsp%3B%20But%20it%20seems%20like%20every%20new%20person%20that%20goes%20to%20this%20list%20for%20the%20first%20time%20has%20to%20do%20this%20view%20switching%20thing%20to%20get%20the%20full%20items%20to%20show%20up%20in%20the%20group%20by%20view.%26nbsp%3B%20And%20i%20can't%20say%20if%20this%20happens%20for%20every%20list%20or%20not.%26nbsp%3B%20We%20just%20happened%20to%20notice%20it%20on%20one%20of%20our%20lists%20that%20was%20in%20group%20by%20mode.%3C%2FP%3E%3C%2FLINGO-BODY%3E
Visitor

Hello, 

 

I have a document library with multiple tags. One of the fields is a dropdown with 3 items. When I do a 'group by' using the dropdown field I can only see groups for 2 items. The 3rd one is just invisible. I have documents tagged to all three options. So all the 3 tags are in use. When I ungroup them they are all visible.

 

Any help will be appreciated.

2 Replies

@dipand

did you ever figure this out?  We recently noticed, with one of our SharePoint Online lists using the modern experience, that when you initially have the default view as a group by view, some of the list items won't show up in one or more of the groups, but then changing the view to All Items and then back to the group by view shows them all.  And then you appear to be fine from that point on.  But it seems like every new person that goes to this list for the first time has to do this view switching thing to get the full items to show up in the group by view.  And i can't say if this happens for every list or not.  We just happened to notice it on one of our lists that was in group by mode.

Updating the view to remove grouping, and then updating it back to be grouped seemed to resolve this for me today.

We support Ukraine and condemn war. Push Russian government to act against war. Be brave, vocal and show your support to Ukraine. Follow the latest news HERE