SOLVED

Teams Calling - Dial pad missing

Occasional Contributor

We have recently migrated all our users from SfB to Teams , and one of my users now is unable to dial out to external phone numbers?

He has a E3 licence, Phone system, Domestic calling plan, Communication credits licences applied, and had his phone number assigned, but he has no dial pad in Teams.

He is able to receive external calls to his Teams phone number? 

I have logged him onto another PC and signed into Teams but the same happens there is no dial pad.

The teams desktop app settings >Calls > has no call answering rules available as if there is no licence assigned.

Has anyone seen this before?

 

rayb no dial pad.png

91 Replies

@Chris Cooper 
Check if the Azure AD Object is actually EV enabled in Azure AD (I have had this and seems/think to be an intermittent issue with provisioning an EV Teams user in the O365)

2019-03-26 14_03_30-rd.mklync.com - Remote Desktop Connection.png

 

If you find this is false then please run:
Get-CsOnlineUser <SIP Address of Effected Teams Users> | Set-CsUser -EnterpriseVoiceEnabled $true

@Mehmet_Kocak Thanks Mehmet, I'm having issues running the powershell command in your screen grab, what module are you connecting to in powershell, how are you connecting to check if the Azure AD Object is actually EV enabled in Azure AD?

Many thanks

No worries, if you follow this link it explains how to connect

https://docs.microsoft.com/en-us/office365/enterprise/powershell/connect-to-all-office-365-services-...

Then if you run just get-csonlineuser <sip address> | select "*voice*","*team*"
Check if the enterprise voice is enabled, and other settings matches expectation compared to your other users that is working

@Mehmet_Kocak  Hi Mehmet, I was following this conversation but it looks like it did not progress. I have upgraded few users to "Teams Only" but we noticed that our dialpad is missing as well hence, we cant make external calls. Ive ran the recommended script above and here's the result.

 

PS C:\will> Get-CsTeamsInteropPolicy

Identity : Global
AllowEndUserClientOverride : False
CallingDefaultClient : Default
ChatDefaultClient : Default

Identity : Tag:DisallowOverrideCallingTeamsChatTeams
AllowEndUserClientOverride : False
CallingDefaultClient : Teams
ChatDefaultClient : Teams

 

May I know if this is an app limitation or there is something I need to enable through powershell. 

 

Please see attached photo for reference.

 

Thanks!

 

William

Heres another screenshot. dial pad is missing

I tried this keyboard shortcuts too but it did not display the dialpad. 

 

 

@WilliamTan30Have you EV enabled your Teams users ? (Phone System Licence, and depending how you route your PSTN Calls Direct Routing Voice Routes and/or PSTN Calling Plan Assignment Voice Routes...)
But at a bear min as far as I know you need to EV Enable your Teams users for the dial pad to appear...

@Mehmet_Kocak how would i know if my EV is enabled?

@Mehmet_Kocak if you are refererring to my Enterprisevoiceenabled, yes this feature is on "true". please see screenshot

@Mehmet_Kocak Hi Mehmet, thanks for this, it turned out, my machine was at fault so I had to connect on a different server, the result were all true, thanks for the help with this. 


@Mehmet_Kocak wrote:
No worries, if you follow this link it explains how to connect

https://docs.microsoft.com/en-us/office365/enterprise/powershell/connect-to-all-office-365-services-...

Then if you run just get-csonlineuser <sip address> | select "*voice*","*team*"
Check if the enterprise voice is enabled, and other settings matches expectation compared to your other users that is working

 

EnterpriseVoiceEnabled : True

 

@Mehmet_Kocak My EVenabled is "True". Please see attached. 

@Mehmet_Kocak Currently our setup is like this;

 

We do not have a calling plan (Denmark) that's why we are using CCE server to connect our calls to SFB

 

I have Enterprise e3, Audioconferencing and Phone system licenses.

 

I hope this would help.

 

Thank you in advance! :)

I had another user yesterday loose their dial pad over night, he had been working fine for weeks but just over night the dial pad went missing? I'm not sure if its a coincidence or what but I just switched his teams to developer mode which logged him out and logged him back in and that brought the dial pad back for this user, I then switched him back and the dial pad stayed so not sure what was going on but unfortunately this did not work for my original user having the same issue as you. 

Chris

@WilliamTan30 So you have OPCH configured (CCE), but your Teams EV Users cannot leverage this feature, as OPCH is only for SfB Online Users consuming telephony via the CCE device, you will need to setup Direct Routing (SIP Trunk between On-prem supported SBC and Teams SBC) and/or use Calling Plans.
I can see that the page shot shows this particular user has not got a CsOnlineVoiceRoute configured which is configuration setting for Teams Direct Routing....
However as a side note sounds like there is some issues in general with the Dial Pad as Chris pointed out above...


@Chris Cooper Thanks for your inputs. This could be an issue or a glitch

 

@Mehmet_Kocak how can I setup a direct routing for Teams SBC? calling plan is still not available in denmark 

@WilliamTan30Yep! I would recommend you read:
https://docs.microsoft.com/en-us/microsoftteams/direct-routing-plan

https://docs.microsoft.com/en-us/microsoftteams/direct-routing-configure

I hope this helps (BTW do not think this is related to your Dial Pad issue and more likely an issue within the MS Teams stack itself)

Thanks

 

Just stumbled across this while searching for answers - I lost my dial pad two days ago! I have Direct Routing via AudioCodes SBC. It was working fine and now it’s gone. I have logged into other PCs and it’s not there.

I have other users working fine, but my acct it’s not. Funny thing - dial pad works fine on the iOS Teams app. I’ll have to check my Mac in the morning.

I have moved my acct back to SfB on-prem and then back to Teams...still no dialpad. No explanation for it, but sounds like we’re suffering from the same ‘issue’.

I checked both Mac and PCs this morning; both exhibit the same behavior.  The dialpad and Voicemail tabs are missing in Teams.  I signed out of Teams and back in and still no dialpad/voicemail.   My iPhone, however, still has the dialpad/voicemail.  I can place/receive calls from iOS Teams just fine.

www.000webhost.com