SOLVED

MS Teams External Chat not working

%3CLINGO-SUB%20id%3D%22lingo-sub-1615261%22%20slang%3D%22en-US%22%3EMS%20Teams%20External%20Chat%20not%20working%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1615261%22%20slang%3D%22en-US%22%3E%3CP%3EHi%2C%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20have%20been%20chatting%20with%20external%20users%20(clients)%20of%20different%20domains%20from%20my%20organizational%20account.%20Suddenly%2C%20this%20has%20stopped%20working.%20Instead%20of%20an%20'External'%20tag%20next%20to%20their%20name%2C%20Now%20I%20see%20the%20user%20as%20'Unknown'.%20The%20more%20worrying%20this%2C%20I%20still%20get%20the%20messages%20from%20them%2C%20but%20I'm%20not%20able%20to%20reply%20to%20them.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ECan%20someone%20help%20me%20with%20this.%20Thanks%20in%20advance!%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-1615261%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EExternal%20Chat%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EGuest%20Access%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EMicrosoft%20Teams%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1615300%22%20slang%3D%22en-US%22%3ERe%3A%20MS%20Teams%20External%20Chat%20not%20working%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1615300%22%20slang%3D%22en-US%22%3E%3CP%3EHi%2C%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EAre%20you%20the%20only%20one%20in%20your%20organisation%20with%20this%20problem%20or%20are%20there%20more%20users%20with%20the%20same%20problem%3F%20If%20there%20is%20changes%20made%20by%20your%20administrator%20for%20Teams%20I%20suggest%20that%20you%20report%20this%20to%20Microsoft%20Support%20via%20the%20Office%20365%20admin%20portal.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1615319%22%20slang%3D%22en-US%22%3ERe%3A%20MS%20Teams%20External%20Chat%20not%20working%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1615319%22%20slang%3D%22en-US%22%3E%3CP%3EIt's%20actually%20everyone%20in%20my%20org%3B%20not%20able%20to%20chat%20with%20external%20users%20%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F9476%22%20target%3D%22_blank%22%3E%40Linus%20Cansby%3C%2FA%3E.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1617381%22%20slang%3D%22en-US%22%3ERe%3A%20MS%20Teams%20External%20Chat%20not%20working%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1617381%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F750082%22%20target%3D%22_blank%22%3E%40nitishkanann23%3C%2FA%3E%26nbsp%3BMake%20sure%20that%20nothing%20been%20changed%20with%20the%20settings%20for%20external%20communications%20by%20admins%3A%3C%2FP%3E%0A%3CP%3E%3CA%20href%3D%22https%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fmicrosoftteams%2Fmanage-external-access%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%22%3Ehttps%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fmicrosoftteams%2Fmanage-external-access%3C%2FA%3E%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3ETest%20in%20the%20web%20client%20%3CA%20href%3D%22https%3A%2F%2Fteams.microsoft.com%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%22%3Ehttps%3A%2F%2Fteams.microsoft.com%3C%2FA%3E%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EAnd%20if%20that%20doesn't%20work%20contact%20Microsoft%20Support.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2139046%22%20slang%3D%22en-US%22%3ERe%3A%20MS%20Teams%20External%20Chat%20not%20working%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2139046%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F750082%22%20target%3D%22_blank%22%3E%40nitishkanann23%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3EWe%20have%20a%20similar%20problem.%20We%20have%20this%20workaround%20for%20the%20problem%20%3A%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EClick%20on%20the%20name%20above%20in%20the%20chat%2C%20write%20a%20message%20in%20that%20chat%20window.%20This%20should%20work.%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20image-alt%3D%22teams.jpg%22%20style%3D%22width%3A%20793px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F255219iF9A0536F13EE15A3%2Fimage-size%2Flarge%3Fv%3D1.0%26amp%3Bpx%3D999%22%20role%3D%22button%22%20title%3D%22teams.jpg%22%20alt%3D%22teams.jpg%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EWe%20have%20a%20MS%20case%20open%20for%20this%20problem%20but%20this%20workaround%20makes%20it%20less%20of%20a%20problem%20for%20us.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EDo%20you%20have%20exchange%20on%20premise%20or%2Fand%20used%20skype%20on%20premise%3F%3C%2FP%3E%3CP%3EIs%20teams%20only%20set%20to%20%22teams%20only%22%20%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2155400%22%20slang%3D%22en-US%22%3ERe%3A%20MS%20Teams%20External%20Chat%20not%20working%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2155400%22%20slang%3D%22en-US%22%3E%3CP%3EAny%20other%20people%20with%20suggestions%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2282616%22%20slang%3D%22en-US%22%3ERe%3A%20MS%20Teams%20External%20Chat%20not%20working%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2282616%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F968117%22%20target%3D%22_blank%22%3E%40MastBob%3C%2FA%3E%26nbsp%3Bdid%20you%20found%20a%20solution%3F%20Same%20problem%20here...%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2289935%22%20slang%3D%22en-US%22%3ERe%3A%20MS%20Teams%20External%20Chat%20not%20working%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2289935%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F88200%22%20target%3D%22_blank%22%3E%40Jef%20Vleugels%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EHello%20Jef%2C%3C%2FP%3E%3CP%3EI%20did%20solve%20it.%20It%20has%20been%20a%20wile%20so%20I%20don't%20know%20exacly%20how%20I%20did%20it%20but%20here%20are%20some%20left%20over%20notes.%20I%20would%20create%20a%20MS%20case%20if%20you%20are%20not%20sure%20about%20the%20following%20commands.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThis%20commands%20to%20connect%20to%20PS%20%3A%3CBR%20%2F%3E%3CBR%20%2F%3EImport-Module%20SkypeOnlineConnector%3CBR%20%2F%3E%24session%20%3D%20New-CsOnlineSession%20-Verbose%20-OverrideAdminDomain%20******.onmicrosoft.com%3CBR%20%2F%3EImport-PSSession%20%24session%20%E2%80%93AllowClobber%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ECommand%20to%20disable%20lync%20on%20premise%20shared%20sip%20space%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ESet-CsTenantFederationConfiguration%20-SharedSipAddressSpace%20%24false%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3Ealso%20changed%20the%20following%20DNS%3C%2FP%3E%3CP%3Elyncdiscover.yourdomain.com%20to%20webdir.online.lync.com%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20do%20remember%20setting%20some%20user%20settings%20from%20hybrid%20to%20online%20online%20but%20not%20sure%20if%20this%20command%20did%20anything%20%3A%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EGet-ADUser%20-Filter%20%7BmsRTCSIP-DeploymentLocator%20-like%20%22SRV*%22%7D%20%7C%3CBR%20%2F%3ESet-ADUser%20-Clear%20msRTCSIP-DeploymentLocator%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2493673%22%20slang%3D%22en-US%22%3ERe%3A%20MS%20Teams%20External%20Chat%20not%20working%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2493673%22%20slang%3D%22en-US%22%3E%3CP%3EThe%20problem%20with%20my%20client%20is%20that%20only%20a%20few%20users%20have%20the%20error.%3C%2FP%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F968117%22%20target%3D%22_blank%22%3E%40MastBob%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2494016%22%20slang%3D%22en-US%22%3ERe%3A%20MS%20Teams%20External%20Chat%20not%20working%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2494016%22%20slang%3D%22en-US%22%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F88200%22%20target%3D%22_blank%22%3E%40Jef%20Vleugels%3C%2FA%3E%3CBR%20%2F%3E%3CBR%20%2F%3EThe%20problem%20with%20my%20client%20is%20that%20only%20a%20few%20users%20have%20the%20error.%3CBR%20%2F%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2496678%22%20slang%3D%22en-US%22%3ERe%3A%20MS%20Teams%20External%20Chat%20not%20working%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2496678%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F1090166%22%20target%3D%22_blank%22%3E%40Lucas_Reis%3C%2FA%3E%26nbsp%3Bcan%20you%20elaborate%20a%20little%20further%3F%20S4B%3F%20Hybrid%3F%20Teams%20migration%3F%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2498853%22%20slang%3D%22en-US%22%3ERe%3A%20MS%20Teams%20External%20Chat%20not%20working%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2498853%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F88200%22%20target%3D%22_blank%22%3E%40Jef%20Vleugels%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CPRE%3E%26nbsp%3B%3C%2FPRE%3E%3CP%3E%26nbsp%3BInside%20my%20tenant%2C%20there%20are%20100%20users%2C%20these%20100%20users%2C%2030%20users%20are%20not%20able%20to%20answer%20the%20external%20Teams%20chat%2C%20the%20other%2070%20users%20are%20responding%20to%20normal%20external%20team%20chat.%20For%20those%20users%20who%20are%20having%20problems%20answering%20the%20Teams%20external%20chat%2C%20the%20following%20error%20is%20appearing%3A%20%22due%20to%20the%20change%20in%20the%20organization's%20policy%2C%20this%20chat%20is%20no%20longer%20available%20to%20use%20Skype%20For%20Business%22.%20Checks%20I've%20already%20done.%20My%20tenant%20and%20the%20tenant%20who%20is%20making%20an%20external%20communication%20are%20without%20teams%20only%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2500742%22%20slang%3D%22en-US%22%3ERe%3A%20MS%20Teams%20External%20Chat%20not%20working%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2500742%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F1090166%22%20target%3D%22_blank%22%3E%40Lucas_Reis%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3ECheck%20teams%20admin%20center%20and%20go%20to%20users.%20Check%20if%20there%20is%20a%20difference%20on%20the%20following%20options%3A%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CUL%3E%3CLI%3EDirectory%20status%3C%2FLI%3E%3CLI%3EInterpreted%20user%20type%3C%2FLI%3E%3C%2FUL%3E%3CP%3Eofcourse%20all%20users%20need%20a%20valid%20license.%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EAlso%20check%20if%20your%20SIP%2Fskype%2Fteams%20Dns%20records%20are%20pointing%20to%20office%20365%20and%20not%20something%20onpremise%20like%20Skype.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fskypeforbusiness%2Fplan-your-deployment%2Fnetwork-requirements%2Fdns%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%22%3EDNS%20requirements%20for%20Skype%20for%20Business%20Server%20-%20Skype%20for%20Business%20Server%202015%20%7C%20Microsoft%20Docs%3C%2FA%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CDIV%20class%3D%22data-table-customization-form__fields___2TcKU%22%3E%3CDIV%20class%3D%22styles__root___2dDCK%22%3E%3CDIV%20class%3D%22styles__container___bu6XU%22%3E%26nbsp%3B%3C%2FDIV%3E%3C%2FDIV%3E%3C%2FDIV%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2502022%22%20slang%3D%22en-US%22%3ERe%3A%20MS%20Teams%20External%20Chat%20not%20working%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2502022%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F968117%22%20target%3D%22_blank%22%3E%40MastBob%3C%2FA%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3Ethe%20interesting%20thing%20is%20with%20some%20users%20that%20this%20happens%2C%20so%20if%20it%20were%20DNS%20it%20would%20be%20a%20problem%20for%20all%20users%3C%2FP%3E%3CP%3EIn%20the%20picture%20below%20there%20is%20a%20difference%20in%20the%20powershell%20window%20on%20the%20left%2C%20the%20user%20who%20works%2C%20on%20the%20right%20side%20of%20the%20user%20who%20doesn't.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2502045%22%20slang%3D%22en-US%22%3ERe%3A%20MS%20Teams%20External%20Chat%20not%20working%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2502045%22%20slang%3D%22en-US%22%3E%3CP%3Eyes%20in%20my%20post%20above%20I%20posted%20a%20command%20to%20clear%20all%20those%20locators.%20I%20think%20it%20was%20this%20one%20%3A%3CBR%20%2F%3E%3CBR%20%2F%3EGet-ADUser%20-Filter%20%7BmsRTCSIP-DeploymentLocator%20-like%20%22SRV*%22%7D%20%7C%3CBR%20%2F%3ESet-ADUser%20-Clear%20msRTCSIP-DeploymentLocator%3CBR%20%2F%3E%3CBR%20%2F%3E%3CA%20href%3D%22http%3A%2F%2Fterenceluk.blogspot.com%2F2020%2F11%2Fpowershell-script-for-clearing-msrtcsip.html%22%20target%3D%22_blank%22%20rel%3D%22nofollow%20noopener%20noreferrer%22%3Ehttp%3A%2F%2Fterenceluk.blogspot.com%2F2020%2F11%2Fpowershell-script-for-clearing-msrtcsip.html%3C%2FA%3E%3CBR%20%2F%3E%3CBR%20%2F%3Eyou%20can%20always%20try%201%20account%20with%20the%20AD%20attribute%20editor%20and%20see%20if%20it%20works%20before%20dooing%20the%20command%20on%20all%20users.%20(%20don't%20forget%20to%20sync%20to%20the%20cloud)%3C%2FP%3E%3CP%3EDooing%20a%20logout%20%2B%20login%20cycle%20for%20teams%20on%20the%20users%20computer%20might%20be%20required.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EIf%20not%20you%20can%20make%20a%20case%20with%20O365%20support%20but%20I%20solved%20it%20myself%20before%20they%20had%20any%20decent%20info%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3Eno%20idea%20why%20this%20happens%20but%20in%20my%20case%20the%20Skype%20on%20prem%20server%20crashed%20before%20we%20could%20decommission%26nbsp%3Bproperly.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2502108%22%20slang%3D%22en-US%22%3ERe%3A%20MS%20Teams%20External%20Chat%20not%20working%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2502108%22%20slang%3D%22en-US%22%3EAlso%20you%20can%20look%20at%20the%20suggestion%20%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F968117%22%20target%3D%22_blank%22%3E%40MastBob%3C%2FA%3E%20made%3A%3CBR%20%2F%3ECheck%20teams%20admin%20center%20and%20go%20to%20users.%20Check%20if%20there%20is%20a%20difference%20on%20the%20following%20options%3A%3CBR%20%2F%3EDirectory%20status%3CBR%20%2F%3EInterpreted%20user%20type%3CBR%20%2F%3E%3CBR%20%2F%3EAlso%20check%20msRTCSIP-DeploymentLocator.%3CBR%20%2F%3E%3CBR%20%2F%3EThere%20is%20probably%20a%20difference%2C%20because%20the%20screenshot%20shows%20a%20different%20hosting%20provider%20and%20an%20internal%20S4B%20server.%20Looks%20like%20some%20users%20are%20moved%20to%20S4B%20Online%20%2F%20Teams%2C%20but%20DNS%20is%20pointing%20to%20internal%20S4B%20server.%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2502128%22%20slang%3D%22en-US%22%3ERe%3A%20MS%20Teams%20External%20Chat%20not%20working%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2502128%22%20slang%3D%22en-US%22%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F968117%22%20target%3D%22_blank%22%3E%40MastBob%3C%2FA%3E%3CBR%20%2F%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F88200%22%20target%3D%22_blank%22%3E%40Jef%20Vleugels%3C%2FA%3E%3CBR%20%2F%3EThank%20you.%3CBR%20%2F%3E%3CBR%20%2F%3Ei'll%20check%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2502171%22%20slang%3D%22en-US%22%3ERe%3A%20MS%20Teams%20External%20Chat%20not%20working%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2502171%22%20slang%3D%22en-US%22%3EDid%20you%20get%20it%20fixed%20Jef%20%3F%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2502193%22%20slang%3D%22en-US%22%3ERe%3A%20MS%20Teams%20External%20Chat%20not%20working%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2502193%22%20slang%3D%22en-US%22%3ENot%20instantly%2C%20but%20your%20information%20helped%20making%20the%20migration%20plan%20from%20a%20complex%20hybrid%20S4B%20environment%20with%20resource%20forest%20and%20appliance%20to%20Teams%20Only%20with%20direct%20routing.%20We%20could%20not%20adjust%20DNS%20nor%20empty%20the%20msRTCSIP-DeploymentLocator%20for%20users%20who%20were%20still%20using%20the%20old%20environment.%20Migration%20is%20almost%20finished%20now.%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2502946%22%20slang%3D%22en-US%22%3ERe%3A%20MS%20Teams%20External%20Chat%20not%20working%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2502946%22%20slang%3D%22en-US%22%3EThe%20command%20was%20successful%2C%20thank%20you%20very%20much.%3CBR%20%2F%3E%3CBR%20%2F%3EThe%20user%20who%20made%20the%20manual%20change%20is%20working%2C%20but%20the%20users%20who%20made%20the%20script%20did%20not.%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2515107%22%20slang%3D%22en-US%22%3ERe%3A%20MS%20Teams%20External%20Chat%20not%20working%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2515107%22%20slang%3D%22en-US%22%3Eso%20the%20script%20does%20not%20work%20for%20you%3F%20Do%20you%20get%20an%20error%3F%3C%2FLINGO-BODY%3E
New Contributor

Hi,

 

I have been chatting with external users (clients) of different domains from my organizational account. Suddenly, this has stopped working. Instead of an 'External' tag next to their name, Now I see the user as 'Unknown'. The more worrying this, I still get the messages from them, but I'm not able to reply to them.

 

Can someone help me with this. Thanks in advance!

19 Replies

Hi,

 

Are you the only one in your organisation with this problem or are there more users with the same problem? If there is changes made by your administrator for Teams I suggest that you report this to Microsoft Support via the Office 365 admin portal.

It's actually everyone in my org; not able to chat with external users @Linus Cansby.

@nitishkanann23 Make sure that nothing been changed with the settings for external communications by admins:

https://docs.microsoft.com/en-us/microsoftteams/manage-external-access

 

Test in the web client https://teams.microsoft.com

 

And if that doesn't work contact Microsoft Support.

@nitishkanann23 

We have a similar problem. We have this workaround for the problem : 

 

Click on the name above in the chat, write a message in that chat window. This should work. 

 

teams.jpg

 

We have a MS case open for this problem but this workaround makes it less of a problem for us.

 

Do you have exchange on premise or/and used skype on premise?

Is teams only set to "teams only" ?

Any other people with suggestions?

@MastBob did you found a solution? Same problem here...

@Jef Vleugels 

 

Hello Jef,

I did solve it. It has been a wile so I don't know exacly how I did it but here are some left over notes. I would create a MS case if you are not sure about the following commands.

 

 

This commands to connect to PS :

Import-Module SkypeOnlineConnector
$session = New-CsOnlineSession -Verbose -OverrideAdminDomain ******.onmicrosoft.com
Import-PSSession $session –AllowClobber

 

Command to disable lync on premise shared sip space

 

Set-CsTenantFederationConfiguration -SharedSipAddressSpace $false

 

also changed the following DNS

lyncdiscover.yourdomain.com to webdir.online.lync.com

 

I do remember setting some user settings from hybrid to online online but not sure if this command did anything :

 

Get-ADUser -Filter {msRTCSIP-DeploymentLocator -like "SRV*"} |
Set-ADUser -Clear msRTCSIP-DeploymentLocator

@Jef Vleugels

The problem with my client is that only a few users have the error.

@Lucas_Reis can you elaborate a little further? S4B? Hybrid? Teams migration? 

@Jef Vleugels 

 

 Inside my tenant, there are 100 users, these 100 users, 30 users are not able to answer the external Teams chat, the other 70 users are responding to normal external team chat. For those users who are having problems answering the Teams external chat, the following error is appearing: "due to the change in the organization's policy, this chat is no longer available to use Skype For Business". Checks I've already done. My tenant and the tenant who is making an external communication are without teams only

@Lucas_Reis 

Check teams admin center and go to users. Check if there is a difference on the following options:

 

  • Directory status
  • Interpreted user type

ofcourse all users need a valid license. 

 

Also check if your SIP/skype/teams Dns records are pointing to office 365 and not something onpremise like Skype.

 

DNS requirements for Skype for Business Server - Skype for Business Server 2015 | Microsoft Docs

 

 

 

 

 

 

 

@MastBob

 

 

the interesting thing is with some users that this happens, so if it were DNS it would be a problem for all users

In the picture below there is a difference in the powershell window on the left, the user who works, on the right side of the user who doesn't.

best response confirmed by ThereseSolimeno (Microsoft)
Solution

yes in my post above I posted a command to clear all those locators. I think it was this one :

Get-ADUser -Filter {msRTCSIP-DeploymentLocator -like "SRV*"} |
Set-ADUser -Clear msRTCSIP-DeploymentLocator

http://terenceluk.blogspot.com/2020/11/powershell-script-for-clearing-msrtcsip.html

you can always try 1 account with the AD attribute editor and see if it works before dooing the command on all users. ( don't forget to sync to the cloud)

Dooing a logout + login cycle for teams on the users computer might be required.

 

If not you can make a case with O365 support but I solved it myself before they had any decent info

 

no idea why this happens but in my case the Skype on prem server crashed before we could decommission properly.

Also you can look at the suggestion @MastBob made:
Check teams admin center and go to users. Check if there is a difference on the following options:
Directory status
Interpreted user type

Also check msRTCSIP-DeploymentLocator.

There is probably a difference, because the screenshot shows a different hosting provider and an internal S4B server. Looks like some users are moved to S4B Online / Teams, but DNS is pointing to internal S4B server.
@MastBob
@Jef Vleugels
Thank you.

i'll check
Did you get it fixed Jef ?
Not instantly, but your information helped making the migration plan from a complex hybrid S4B environment with resource forest and appliance to Teams Only with direct routing. We could not adjust DNS nor empty the msRTCSIP-DeploymentLocator for users who were still using the old environment. Migration is almost finished now.
The command was successful, thank you very much.

The user who made the manual change is working, but the users who made the script did not.
so the script does not work for you? Do you get an error?
www.000webhost.com