Microsoft Flow: @mention action not working for Teams reply

%3CLINGO-SUB%20id%3D%22lingo-sub-1593455%22%20slang%3D%22de-DE%22%3EMicrosoft%20Flow%3A%20%40mention%20action%20not%20working%20for%20Teams%20reply%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1593455%22%20slang%3D%22de-DE%22%3E%3CP%3EHi%3C%2FP%3E%3CP%3EI'm%20currently%20working%20on%20a%20flow%20that%20should%20be%20automatically%20called%20when%20a%20new%20mail%20arrives%20in%20a%20teams%20channel.%20This%20mail%20is%20from%20a%20facility%20information%20service%20an%20provides%20info%20regarding%20packages%20and%20guests.%3C%2FP%3E%3CP%3EAs%20there%20is%20no%20specific%20notification%20for%20this%20mail%20and%20so%20guest%20could%20be%20overseen%2C%20I%20want%20to%20add%20a%20mention%20notification%20to%20this%20mail%20in%20the%20channel.%3C%2FP%3E%3CP%3EI%20tried%20with%20an%20automatic%20flow%2C%20with%20the%20trigger%20%22when%20a%20new%20post%20is%20added%20to%20a%20channel%22%20and%20then%20a%20condition%20with%20%22if%20the%20sender%20from%20name%20is%20%22SENDERNAME%22%20is%20true%22%20then%20call%20a%20%22get%20mention%20token%20for%20a%20user%22%20action%20and%20add%20this%20token%20to%20the%20%22reply%20to%20message%20in%20teams%22%20action.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EBut%20as%20soon%20as%20I%20add%20the%20mention%20token%20action%20my%20flow%20ends%20in%20errors%20saying%20that%20I%20%22should%20correct%20invalid%20inputs%20for%20the%20condition%22%20and%20%22correct%20invalid%20inputs%20for%20my%20reply%20to%20message%22%20action.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20have%20no%20clue%20why%20these%20errors%20exist%2C%20I%20have%20access%20to%20the%20team%20and%20channel%2C%20logged%20into%20a%20teams%20session%20in%20flow%20and%20so%20on.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ECan%20anyone%20help%20me%20in%20there%3F%3C%2FP%3E%3CP%3EIf%20infos%20are%20needed%20to%20solve%20this%2C%20just%20ask%20%3B)%3C%2Fimg%3E%20%3CBR%20%2F%3E%3CBR%20%2F%3E%20Thanks%20and%20Regards!%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-1593455%22%20slang%3D%22de-DE%22%3E%3CLINGO-LABEL%3EChannel%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EFlow%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EMention%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3ETeams%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1594569%22%20slang%3D%22en-US%22%3ERe%3A%20Microsoft%20Flow%3A%20%40mention%20action%20not%20working%20for%20Teams%20reply%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1594569%22%20slang%3D%22en-US%22%3E%3CP%3EHey%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F634066%22%20target%3D%22_blank%22%3E%40Julian12%3C%2FA%3E%26nbsp%3B%2C%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ECouple%20of%20places%20you%20could%20have%20gone%20wrong%2C%20here%20is%20a%20working%20screenshot%20reference%3A%3C%2FP%3E%3CP%3EFirst%20off%20the%20end%20result%3B%20note%20that%20message%20posted%20in%20teams%20says%20%22Via%20email%22%20when%20someone%20posts%20email%20to%20channel%20%3A%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20image-alt%3D%22TeamsFlowResponse3.JPG%22%20style%3D%22width%3A%20400px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F212870i436B1C1F1B9F75A8%2Fimage-size%2Fmedium%3Fv%3D1.0%26amp%3Bpx%3D400%22%20title%3D%22TeamsFlowResponse3.JPG%22%20alt%3D%22TeamsFlowResponse3.JPG%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3ESo%2C%20Instead%20of%20using%20the%20condition%20%22if%20the%20sender%20from%20name%20is%22%20a%20better%20option%20would%20be%20%22Message%20from%20display%20name%20contains%22%20like%3A%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20image-alt%3D%22TeamsFlowResponse1.JPG%22%20style%3D%22width%3A%20400px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F212871iCEEC570B9677B78F%2Fimage-size%2Fmedium%3Fv%3D1.0%26amp%3Bpx%3D400%22%20title%3D%22TeamsFlowResponse1.JPG%22%20alt%3D%22TeamsFlowResponse1.JPG%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ENext%20make%20sure%20the%20flow%20is%20replying%20to%20the%20right%20message%2C%20Use%20%22Message%20ID%22%20(unique%20for%20every%20message)%20for%20this%20%3A%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20image-alt%3D%22TeamsFlowResponse2.JPG%22%20style%3D%22width%3A%20400px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F212872iE2CCF6C9E453CB0A%2Fimage-size%2Fmedium%3Fv%3D1.0%26amp%3Bpx%3D400%22%20title%3D%22TeamsFlowResponse2.JPG%22%20alt%3D%22TeamsFlowResponse2.JPG%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3Eand%20that%20should%20do%20the%20trick.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThanks%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1596834%22%20slang%3D%22en-US%22%3ERe%3A%20Microsoft%20Flow%3A%20%40mention%20action%20not%20working%20for%20Teams%20reply%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1596834%22%20slang%3D%22en-US%22%3E%3CP%3EHi%20%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F67895%22%20target%3D%22_blank%22%3E%40harveer%20singh%3C%2FA%3E%2C%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3Ethanks%20for%20your%20detailed%20explanation!%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20rebuilt%20my%20flow%20with%20the%20exact%20same%20objects%20and%20values%20to%20your%20example%20but%20still%20I'm%20getting%20these%20nasty%20errors.%20I%20even%20tried%20other%20channels%20and%20other%20users%20with%20which%20I%20built%20the%20flow%2C%20still%20no%20luck.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EFollowing%20is%20a%20screenshot%20of%20my%20current%20flow%2C%20though%20in%20german%20but%20should%20be%20same%20elements%3A%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20image-alt%3D%22Julian12_0-1597774795924.png%22%20style%3D%22width%3A%20400px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F213131iBED47F9AF671D8B1%2Fimage-size%2Fmedium%3Fv%3D1.0%26amp%3Bpx%3D400%22%20title%3D%22Julian12_0-1597774795924.png%22%20alt%3D%22Julian12_0-1597774795924.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3EMaybe%20you%20notice%20something.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThe%20errors%20occur%20as%20soon%20as%20I%20add%20the%26nbsp%3B%20mention%20Token%20action%20to%20the%20flow%2C%20first%20for%20the%20condition%20and%20as%20as%20soon%20as%20I%20add%20the%20last%20reply%20to%20message%20action%2C%20the%202nd%20error%20is%20popping%20up%5E%5E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EBest%20Regards%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1596869%22%20slang%3D%22en-US%22%3ERe%3A%20Microsoft%20Flow%3A%20%40mention%20action%20not%20working%20for%20Teams%20reply%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1596869%22%20slang%3D%22en-US%22%3E%3CP%3EHey%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F634066%22%20target%3D%22_blank%22%3E%40Julian12%3C%2FA%3E%26nbsp%3B%2C%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ECan%20you%20try%20nullifying%20the%20other%20condition%2C%20the%20one%20where%20there%20is%20no%20match%2C%20also%20can%20you%20try%20to%20use%20mention%20for%20some%20other%20user.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThanks%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1598241%22%20slang%3D%22en-US%22%3ERe%3A%20Microsoft%20Flow%3A%20%40mention%20action%20not%20working%20for%20Teams%20reply%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1598241%22%20slang%3D%22en-US%22%3EWhat%20do%20you%20mena%20with%20nullifying%20the%20False%20condition%3F%20Simply%20leaving%20it%20empty%3F%3CBR%20%2F%3EI%20tried%20that%20too%2C%20but%20no%20change.%3CBR%20%2F%3EI%20tried%20with%20moving%20the%20get-mention%20token%20action%20to%20differentplaces%20but%20it%20produces%20everywhere%20even%20when%20I%20remove%20the%20condition%20and%20only%20the%20trigger%20-%26gt%3B%20mention%20-%26gt%3B%20reply%20message%20actions%20are%20left%5E%5E%3CBR%20%2F%3EIt's%20always%20saying%20that%20the%20Inputparameters%20for%20the%20following%20action%20after%20the%20mention%20token%20action%20has%20an%20invalid%20expression%3F%3CBR%20%2F%3E%3CBR%20%2F%3EAre%20there%20any%20logs%20or%20deeper%20error%20descriptions%20available%20in%20Flow%3F%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1598501%22%20slang%3D%22en-US%22%3ERe%3A%20Microsoft%20Flow%3A%20%40mention%20action%20not%20working%20for%20Teams%20reply%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1598501%22%20slang%3D%22en-US%22%3EYour%20logic%20looks%20correct%2C%20am%20thinking%20the%20reason%20it%20works%20for%20me%20and%20not%20for%20you%20with%20the%20same%20logic%20could%20be%20that%20the%20feature%20is%20still%20in%20preview%2C%20this%20feature%20has%20been%20a%20long%20standing%20ask%20from%20flow%20community%20and%20finally%20MS%20put%20it%20into%20action%20to%20some%20extent%2C%20here%20is%20another%20article%20from%20Pieter%20who%20was%20able%20to%20achieve%20it%20with%20the%20same%20logic%20%3A%20%3CA%20href%3D%22https%3A%2F%2Fsharepains.com%2F2020%2F07%2F07%2Fmention-microsoft-teams-power-automate%2F%22%20target%3D%22_blank%22%20rel%3D%22nofollow%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fsharepains.com%2F2020%2F07%2F07%2Fmention-microsoft-teams-power-automate%2F%3C%2FA%3E%3CBR%20%2F%3E%3CBR%20%2F%3ETry%20using%20%40mention%20with%20a%20single%20brach%20as%20shown%20in%20the%20above%20article%20and%20if%20it%20still%20doesn't%20work%20am%20thinking%20you%20might%20just%20have%20to%20wait%20for%20it%2C%20if%20it%20is%20workable%20for%20the%20time%20being%2C%20you%20can%20go%20with%20the%20older%20approach%20to%20achieve%20this%20by%20citing%20the%20flow%20bot%20to%20post%20a%20response%2C%20doesn't%20look%20neat%20but%20that's%20all%20we%20had%20back%20then%20%3A%3CBR%20%2F%3E%3CA%20href%3D%22https%3A%2F%2Fpowerusers.microsoft.com%2Ft5%2FBuilding-Flows%2FCan-you-Mention-anyone-in-Teams-from-a-flow%2Fm-p%2F269667%23M27395%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%22%3Ehttps%3A%2F%2Fpowerusers.microsoft.com%2Ft5%2FBuilding-Flows%2FCan-you-Mention-anyone-in-Teams-from-a-flow%2Fm-p%2F269667%23M27395%3C%2FA%3E%3CBR%20%2F%3E%3CBR%20%2F%3EThanks%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1598538%22%20slang%3D%22en-US%22%3ERe%3A%20Microsoft%20Flow%3A%20%40mention%20action%20not%20working%20for%20Teams%20reply%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1598538%22%20slang%3D%22en-US%22%3EI%20know%20this%20article%2C%20curiously%20in%20his%20example%20the%20User%20is%20evaluated%20as%20real%20account%20and%20not%20just%20a%20string%20value.%20This%20doesn't%20seem%20to%20work%20at%20the%20moment%20at%20all.%3CBR%20%2F%3EI%20tried%20even%20with%20a%20manuall%20trigger%20but%20as%20soon%20as%20I%20want%20to%20add%20the%20mention%20token%20to%20any%20following%20action%20similar%20which%20action%2C%20the%20flow%20goes%20to%20error%20state%5E%5E%3CBR%20%2F%3EJust%20checked%20while%20answering%2C%20it%20fails%20even%20if%20I%20include%20a%20manual%20trigger%20and%20set%20as%20User%20the%20dynamic%20userid%20who%20triggers%20the%20flow.%3CBR%20%2F%3E%3CBR%20%2F%3ESo%20this%20seems%20pretty%20bugged%20atm%2C%20I%20will%20have%20a%20look%20at%20the%20flow%20bot%20cards%20now..%3CBR%20%2F%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1603281%22%20slang%3D%22en-US%22%3ERe%3A%20Microsoft%20Flow%3A%20%40mention%20action%20not%20working%20for%20Teams%20reply%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1603281%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F67895%22%20target%3D%22_blank%22%3E%40harveer%20singh%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI'm%20currently%20testing%20without%20the%20mention%20token%20action%20and%20I%20simply%20added%20in%20the%20code%20%3CAT%3EUSERMAIL%3C%2FAT%3E%20which%20is%20working%20for%20single%20users%20now%20at%20least%20%3A)%3C%2Fimg%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EDo%20you%20have%20an%20idea%20with%20which%20method%20or%20string%20I%20can%20mention%20a%20whole%20channel%3F%3C%2FP%3E%3CP%3EI%20tried%20with%20its%20name%2C%20channel-ID%20and%20the%20channel%20mailadress%2C%20without%20success.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EBest%20Regards%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1606854%22%20slang%3D%22en-US%22%3ERe%3A%20Microsoft%20Flow%3A%20%40mention%20action%20not%20working%20for%20Teams%20reply%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1606854%22%20slang%3D%22en-US%22%3E%3CP%3EHello%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F634066%22%20target%3D%22_blank%22%3E%40Julian12%3C%2FA%3E%26nbsp%3B%2C%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ESorry%20for%20a%20delayed%20response%2C%20were%20you%20able%20to%20get%20it%20working%20%3F%20I%20have%20not%20tested%20'mention%20channel'%20with%20flow%20but%20it%20should%20be%20achievable%20using%20Graph%20beta.%20Hopefully%20you%20have%20already%20found%20Denis'%20blog%2C%20if%20not%20here%20is%20a%20reference%3A%26nbsp%3B%3CA%20href%3D%22http%3A%2F%2Fwww.expiscornovus.com%2F2019%2F05%2F29%2Fmention-a-channel-with-flow%2F%22%20target%3D%22_blank%22%20rel%3D%22nofollow%20noopener%20noreferrer%22%3Ehttp%3A%2F%2Fwww.expiscornovus.com%2F2019%2F05%2F29%2Fmention-a-channel-with-flow%2F%3C%2FA%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ETo%20use%20the%20logic%20mentioned%20in%20the%20blog%2C%20you%20will%20have%20to%20setup%20graph%20access%20to%20the%20environment%20first%2C%20basically%20just%20navigate%20to%20graph%20explorer%3A%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Fdeveloper.microsoft.com%2Fen-us%2Fgraph%2Fgraph-explorer%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%22%3Ehttps%3A%2F%2Fdeveloper.microsoft.com%2Fen-us%2Fgraph%2Fgraph-explorer%3C%2FA%3E%26nbsp%3Bset%20the%20mode%20to%20beta%2C%20play%20around%20with%20adding%20the%20right%20permissions%20to%20allow%20an%20http%20POST%20possible%20to%20a%20teams%20channel%2C%20permissions%20reference%20for%20graph%3A%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fgraph%2Fpermissions-reference%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%22%3Ehttps%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fgraph%2Fpermissions-reference%3C%2FA%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EOnce%20you%20have%20graph%20setup%20properly%20you%20should%20be%20able%20to%20post%20a%20message%20from%20within%20graph%20explorer%2C%20use%20the%20navigation%20pane%20on%20left%20to%20choose%20%22post%20in%20channel%22%20the%20query%20should%20look%20like%20this%3A%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Fgraph.microsoft.com%2Fbeta%2Fteams%2F%257Bteam-id%257D%2Fchannels%2F%257Bchannel-id%257D%2Fmessages%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%22%3Ehttps%3A%2F%2Fgraph.microsoft.com%2Fbeta%2Fteams%2F%257Bteam-id%257D%2Fchannels%2F%257Bchannel-id%257D%2Fmessages%3C%2FA%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EIf%20you%20are%20able%20to%20post%20via%20graph%20explorer%20like%20this%2C%20then%20you%20have%20to%20just%20simply%20use%20the%20same%20query%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Fgraph.microsoft.com%2Fbeta%2Fteams%2F%257Bteam-id%257D%2Fchannels%2F%257Bchannel-id%257D%2Fmessages%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%22%3Ehttps%3A%2F%2Fgraph.microsoft.com%2Fbeta%2Fteams%2F%257Bteam-id%257D%2Fchannels%2F%257Bchannel-id%257D%2Fmessages%3C%2FA%3E%26nbsp%3Bin%20a%20http%20post%20message%20as%20per%20the%20blog.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThis%20is%20still%20in%20Beta%20and%20i%20have%20not%20tested%20it%2C%20so%20cant%20assure%20that%20it%20would%20work%20great%2C%20but%20surely%20it%20looks%20possible%20and%20this%20is%20all%20we%20have%20for%20now.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThanks%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1612930%22%20slang%3D%22en-US%22%3ERe%3A%20Microsoft%20Flow%3A%20%40mention%20action%20not%20working%20for%20Teams%20reply%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1612930%22%20slang%3D%22en-US%22%3E%3CP%3EHi%20%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F67895%22%20target%3D%22_blank%22%3E%40harveer%20singh%3C%2FA%3E%2C%3C%2FP%3E%3CP%3Ecurrently%20it's%20only%20working%20for%20a%20single%20user.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20already%20tried%20this%20method%20with%20a%20HTTP%20request%20but%20it%20seems%20that%20I%20need%20a%20premium%20flow%20license%20to%20use%20this%20action%2C%20which%20I%20don't%20have.%20So%20this%20is%20stuck%20again.%3C%2FP%3E%3CP%3EConnecting%20to%20graph%20API%20and%20doing%20things%20is%20no%20problem%2C%20I%20already%20tested%20a%20few%20things%20with%20it%20and%20they%20working%20fine.%3C%2FP%3E%3CP%3EI%20will%20have%20a%20look%20later%20again%2C%20currently%20enjoying%20my%20holidays%20%3A)%3C%2Fimg%3E%3C%2FP%3E%3CP%3EHave%20a%20nice%20week!%3C%2FP%3E%3C%2FLINGO-BODY%3E
Contributor

Hi,

I'm currently working on a Flow which should be automatically called when a new mail arrives in a teams channel. This mail is from a facility information service an provides info regarding packages and guests.

As there is no specific notification for this mail and so guest could be overseen, I want to add a mention notification to this mail in the channel.

I tried with an automatic flow, with the trigger "when a new post is added to a channel" and then a condition with "if the sender from name is "SENDERNAME" is true" then call a "get mention token for a user" action and add this token to the "reply to message in teams" action.

 

But as soon as I add the mention token action my flow ends in errors saying that I "should correct invalid inputs for the condition" and "correct invalid inputs for my reply to message" action.

 

I have no clue why these errors exist, I have access to the team and channel, logged into a teams session in flow and so on.

 

Can anyone help me in there?

If infos are needed to solve this, just ask ;)

Thanks and Regards!

9 Replies

Hey @Julian12 ,

 

Couple of places you could have gone wrong, here is a working screenshot reference:

First off the end result; note that message posted in teams says "Via email" when someone posts email to channel :

 

TeamsFlowResponse3.JPG

So, Instead of using the condition "if the sender from name is" a better option would be "Message from display name contains" like:

TeamsFlowResponse1.JPG

 

Next make sure the flow is replying to the right message, Use "Message ID" (unique for every message) for this :

TeamsFlowResponse2.JPG

and that should do the trick.

 

Thanks

 

Hi @harveer singh,

 

thanks for your detailed explanation!

 

I rebuilt my flow with the exact same objects and values to your example but still I'm getting these nasty errors. I even tried other channels and other users with which I built the flow, still no luck.

 

Following is a screenshot of my current flow, though in german but should be same elements:

Julian12_0-1597774795924.png

Maybe you notice something.

 

The errors occur as soon as I add the  mention Token action to the flow, first for the condition and as as soon as I add the last reply to message action, the 2nd error is popping up^^

 

Best Regards

Hey @Julian12 ,

 

Can you try nullifying the other condition, the one where there is no match, also can you try to use mention for some other user.

 

Thanks

What do you mena with nullifying the False condition? Simply leaving it empty?
I tried that too, but no change.
I tried with moving the get-mention token action to differentplaces but it produces everywhere even when I remove the condition and only the trigger -> mention -> reply message actions are left^^
It's always saying that the Inputparameters for the following action after the mention token action has an invalid expression?

Are there any logs or deeper error descriptions available in Flow?
Your logic looks correct, am thinking the reason it works for me and not for you with the same logic could be that the feature is still in preview, this feature has been a long standing ask from flow community and finally MS put it into action to some extent, here is another article from Pieter who was able to achieve it with the same logic : https://sharepains.com/2020/07/07/mention-microsoft-teams-power-automate/

Try using @mention with a single brach as shown in the above article and if it still doesn't work am thinking you might just have to wait for it, if it is workable for the time being, you can go with the older approach to achieve this by citing the flow bot to post a response, doesn't look neat but that's all we had back then :
https://powerusers.microsoft.com/t5/Building-Flows/Can-you-Mention-anyone-in-Teams-from-a-flow/m-p/2...

Thanks
I know this article, curiously in his example the User is evaluated as real account and not just a string value. This doesn't seem to work at the moment at all.
I tried even with a manuall trigger but as soon as I want to add the mention token to any following action similar which action, the flow goes to error state^^
Just checked while answering, it fails even if I include a manual trigger and set as User the dynamic userid who triggers the flow.

So this seems pretty bugged atm, I will have a look at the flow bot cards now..

@harveer singh 

I'm currently testing without the mention token action and I simply added in the code <at>USERMAIL</at> which is working for single users now at least :)

 

Do you have an idea with which method or string I can mention a whole channel?

I tried with its name, channel-ID and the channel mailadress, without success.

 

Best Regards

Hello @Julian12 ,

 

Sorry for a delayed response, were you able to get it working ? I have not tested 'mention channel' with flow but it should be achievable using Graph beta. Hopefully you have already found Denis' blog, if not here is a reference: http://www.expiscornovus.com/2019/05/29/mention-a-channel-with-flow/

 

To use the logic mentioned in the blog, you will have to setup graph access to the environment first, basically just navigate to graph explorer: https://developer.microsoft.com/en-us/graph/graph-explorer set the mode to beta, play around with adding the right permissions to allow an http POST possible to a teams channel, permissions reference for graph: https://docs.microsoft.com/en-us/graph/permissions-reference

 

Once you have graph setup properly you should be able to post a message from within graph explorer, use the navigation pane on left to choose "post in channel" the query should look like this: https://graph.microsoft.com/beta/teams/%7Bteam-id%7D/channels/%7Bchannel-id%7D/messages

 

If you are able to post via graph explorer like this, then you have to just simply use the same query https://graph.microsoft.com/beta/teams/%7Bteam-id%7D/channels/%7Bchannel-id%7D/messages in a http post message as per the blog.

 

This is still in Beta and i have not tested it, so cant assure that it would work great, but surely it looks possible and this is all we have for now.

 

Thanks

Hi @harveer singh,

currently it's only working for a single user.

 

I already tried this method with a HTTP request but it seems that I need a premium flow license to use this action, which I don't have. So this is stuck again.

Connecting to graph API and doing things is no problem, I already tested a few things with it and they working fine.

I will have a look later again, currently enjoying my holidays :)

Have a nice week!

www.000webhost.com