SOLVED

Document Library tab: Cannot upload or drag&drop files (Bug)

%3CLINGO-SUB%20id%3D%22lingo-sub-1762729%22%20slang%3D%22en-US%22%3EDocument%20Library%20tab%3A%20Cannot%20upload%20or%20drag%26amp%3Bdrop%20files%20(Bug)%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1762729%22%20slang%3D%22en-US%22%3E%3CP%3EHi%2C%3CBR%20%2F%3E%3CBR%20%2F%3EI%20have%20been%20running%20in%20circles%20with%20support%20and%20I%20am%20not%20getting%20anywhere%2C%20i%20need%20to%20raise%20my%20concern%20about%20a%20bug%20in%20MS%20Teams%20which%20causes%20your%20uploaded%20sharepoint%20files%20to%20be%20corrupt%2C%20and%20lose%20all%20contents.%3CBR%20%2F%3EI%20have%20reproduced%20this%20in%203%20different%20tenants%20now%2C%20for%20multiple%20users%20and%20multiple%20computers%2C%20it%20absolutely%20is%20a%20bug.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThe%20bug%20exists%20int%20he%20%22document%20library%22%20tab%20within%20a%20team%20and%20the%20repro%20steps%20are%20simple%3A%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CUL%3E%3CLI%3E%3CSPAN%3Ecreate%20a%20new%20or%20use%20an%20existing%20team.%3C%2FSPAN%3E%3C%2FLI%3E%3CLI%3Eadd%20the%20%22document%20library%22%20app%20for%20any%20sharepoint%20library%3C%2FLI%3E%3CLI%3Ein%20the%20teams%20client%20(web%20or%20desktop)%20drag%26amp%3Bdrop%20a%20file%20into%20this%20library.%3C%2FLI%3E%3CLI%3Eteams%20gives%20an%20error%3A%20failed%20to%20upload%20file%2C%20%22Please%20check%20if%20the%20site%20is%20available.....%22%3C%2FLI%3E%3CLI%3Ethe%20site%20is%20available%2C%20of%20course%2C%20you%20can%20still%20upload%20files%20into%20sharepoint%20directly.%3C%2FLI%3E%3CLI%3Ethe%20file%20which%20failed%20to%20upload%20be%20seen%20in%20sharepoint%20but%20IS%20CORRUPT%20AND%20CANNOT%20BE%20OPENED%3CBR%20%2F%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20image-alt%3D%22blob1601562024091.png%22%20style%3D%22width%3A%20400px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F225323i79DE4BA71093DA03%2Fimage-size%2Fmedium%3Fv%3D1.0%26amp%3Bpx%3D400%22%20title%3D%22blob1601562024091.png%22%20alt%3D%22blob1601562024091.png%22%20%2F%3E%3C%2FSPAN%3E%3CP%3E%E2%80%83%3C%2FP%3E%3C%2FLI%3E%3C%2FUL%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20raised%20this%20with%20support%20but%20as%20usual%20it%20is%20not%20going%20anywhere.%20they%20want%20to%20have%20a%203%20hour%20call%20collecting%20HAR%20files%20and%20fiddler%20logs%20etc%2C%20and%20want%20to%20spend%20the%20next%20few%20weeks%20asking%20me%20about%20my%20laptop-%20no%20thanks.%3CBR%20%2F%3EAlso%20raised%20it%20in%20uservoice%20but%20I%20doubt%20it%20will%20get%20any%20attention%3A%26nbsp%3B%3CBR%20%2F%3E%3CA%20href%3D%22https%3A%2F%2Fmicrosoftteams.uservoice.com%2Fforums%2F908686-bug-reports%2Fsuggestions%2F41580901-document-library-tab-cannot-upload-or-drag-drop-f%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%22%3Ehttps%3A%2F%2Fmicrosoftteams.uservoice.com%2Fforums%2F908686-bug-reports%2Fsuggestions%2F41580901-document-library-tab-cannot-upload-or-drag-drop-f%3C%2FA%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EIf%20we%20as%20users%20find%20a%20bug%20(A%20bad%201...%20which%20affects%20all%20tenants%20and%20causes%20our%20files%20to%20become%20corrupt.....%20for%20example)%20HOW%20can%20we%20escalate%20these%20effectively%3F%20this%20is%20hopeless%3C%2FP%3E%3CP%3E%3CBR%20%2F%3E%3CBR%20%2F%3E%3CBR%20%2F%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-1762729%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EApp%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EDocument%20Library%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3ESharePoint%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1762785%22%20slang%3D%22en-US%22%3ERe%3A%20Document%20Library%20tab%3A%20Cannot%20upload%20or%20drag%26amp%3Bdrop%20files%20(Bug)%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1762785%22%20slang%3D%22en-US%22%3EHey!%20I%20checked%20this%20in%202%20tenants.%20I%20can%20not%20reproduce%20this%20behavior.%20Do%20you%20using%20a%20proxy%3F%20Checked%20with%20a%20direct%20internet%20connection%20without%20any%20between%3F%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1762813%22%20slang%3D%22en-US%22%3ERe%3A%20Document%20Library%20tab%3A%20Cannot%20upload%20or%20drag%26amp%3Bdrop%20files%20(Bug)%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1762813%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F815951%22%20target%3D%22_blank%22%3E%40TheM365Guy%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3Ehi%2C%20thanks%20for%20being%20engaged.%3C%2FP%3E%3CP%3EI%20just%20tested%20again.%3CBR%20%2F%3EToday%20the%20error%20in%20the%20Teams%20client%20is%20gone.%3C%2FP%3E%3CP%3EHowever%2C%20the%20files%20that%20i%20uploaded%20are%20still%20corrupt%20(and%20this%20is%20the%20main%20issue).%3C%2FP%3E%3CP%3EIf%20you%20check%201%20of%20the%20files%20you%20uploaded%20via%20teams%20client%2C%20can%20you%20see%20the%20content%3F%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EFor%20me%2C%20they%20all%20look%20like%20this%3A%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20image-alt%3D%222020-10-09%2009_37_22-DOCX%20File%20viewer%20_%20Microsoft%20Teams.png%22%20style%3D%22width%3A%20400px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F225325i0886C1EDCFB80DFE%2Fimage-size%2Fmedium%3Fv%3D1.0%26amp%3Bpx%3D400%22%20role%3D%22button%22%20title%3D%222020-10-09%2009_37_22-DOCX%20File%20viewer%20_%20Microsoft%20Teams.png%22%20alt%3D%222020-10-09%2009_37_22-DOCX%20File%20viewer%20_%20Microsoft%20Teams.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EAlso%2C%20please%20make%20sure%20that%20the%20%22document%20library%22%20tab%20you%20added%20is%20to%20a%20sharepoint%20site%20(preferrably%20NOT%20the%20same%20site%20created%20by%20the%20team%20automatically.)%20i%20will%20say%20this%3A%20This%20bug%20does%20not%20exist%20on%26nbsp%3B%3CEM%3Esome%3C%2FEM%3E%20libraries%20i%20tested%2C%20but%20for%26nbsp%3B%3CEM%3Emost%3C%2FEM%3E%20of%20them%2C%20it%20does...%20if%20you%20could%2C%20can%20you%20please%20try%20libraries%20from%20a%20few%20different%20site%20collections%3F%20Honestly%20i%20can't%20identify%20which%20libraries%20are%2Fare%20not%20affected%20but%20from%20what%20i%20have%20seen%2C%20most%20libraries%20are%20affected.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EOh!%20and%20to%20answer%20your%20question%3A%3CBR%20%2F%3Eno%2C%20i%20am%20not%20using%20a%20proxy.%3CBR%20%2F%3E2%20colleagues%20(both%20working%20from%20home)%20reproduced%20this%20yesterday%2C%20and%20so%20did%20a%20microsoft%20support%20agent%2C%20so%20i%20really%20dont%20think%20it%20is%20related%20to%20tenant%2C%20user%2C%20computer%2C%20network.%3C%2FP%3E%3CP%3E%E2%80%83%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1762855%22%20slang%3D%22en-US%22%3ERe%3A%20Document%20Library%20tab%3A%20Cannot%20upload%20or%20drag%26amp%3Bdrop%20files%20(Bug)%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1762855%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F499695%22%20target%3D%22_blank%22%3E%40alexrademeyer%3C%2FA%3E%26nbsp%3BI%20did%20it%20like%20described.%20No%20issues%2C%20I%20can%20upload%20the%20files.%20I%20can%20access%20the%20files.%20Also%20I%20checked%20this%20now%20with%203%20different%20document%20libraries.%20One%20with%20a%20team%20created%20library%2C%20two%20with%20some%20complete%20different%20SharePoint%20libraries%2C%20I%20can%20not%20reproduce%20this%20issue.%26nbsp%3B%3C%2FP%3E%3CP%3EOur%20tenant%20is%20based%20in%20EMEA%2C%20just%20as%20information.%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1762864%22%20slang%3D%22en-US%22%3ERe%3A%20Document%20Library%20tab%3A%20Cannot%20upload%20or%20drag%26amp%3Bdrop%20files%20(Bug)%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1762864%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F815951%22%20target%3D%22_blank%22%3E%40TheM365Guy%3C%2FA%3E%26nbsp%3B%3CBR%20%2F%3E%3CBR%20%2F%3Eok%2C%20thank%20you%20for%20taking%20the%20time%20to%20troubleshoot%20%3A)%3C%2Fimg%3E%3CBR%20%2F%3E%3CBR%20%2F%3EI%20have%20tested%20in%20our%20Live%20tenant%2C%20my%20dev%20tenant%2C%20and%20also%20a%20microsoft%20support%20agent%20(in%20Asia%20somewhere)%20tested%20in%20his%20tenant-%20all%203%20were%20affected.%3CBR%20%2F%3E%3CBR%20%2F%3EInteresting%20to%20hear%20that%20yours%20are%20not....%20this%20might%20help%20us%20get%20closer%20to%20an%20answer.%3CBR%20%2F%3E%3CBR%20%2F%3EThanks%20again.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1770321%22%20slang%3D%22en-US%22%3ERe%3A%20Document%20Library%20tab%3A%20Cannot%20upload%20or%20drag%26amp%3Bdrop%20files%20(Bug)%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1770321%22%20slang%3D%22en-US%22%3E%3CP%3EMicrosoft%20support%20have%20confirmed%20that%20the%20product%20team%20are%20aware%20of%20this%20bug%3A%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20image-alt%3D%22alexrademeyer_0-1602485474281.png%22%20style%3D%22width%3A%20569px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F225905i681112B1071EB31E%2Fimage-dimensions%2F569x202%3Fv%3D1.0%22%20width%3D%22569%22%20height%3D%22202%22%20role%3D%22button%22%20title%3D%22alexrademeyer_0-1602485474281.png%22%20alt%3D%22alexrademeyer_0-1602485474281.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EUnfortunately%20i%20still%20don't%20see%20the%20bug%20documented%26nbsp%3B%3CEM%3Eanywhere......%20service%20health%2C%20message%20center%2C%20here%20(besides%20my%20post)%20and%20the%20result%20is%20that%20customer%20files%20are%20becoming%20corrupt%20and%20customers%20are%20losing%20data.%3C%2FEM%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CEM%3Eso%2C%20back%20to%20my%20original%20post%3A%3CBR%20%2F%3EHOW%20are%20we%20supposed%20to%20raise%20bugs%20and%20product%20issues%20in%20an%20efficient%20way%2C%20how%20do%20we%20get%20Microsoft%20to%20admit%20and%20fix%20such%20issues.%3C%2FEM%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1771157%22%20slang%3D%22en-US%22%3ERe%3A%20Document%20Library%20tab%3A%20Cannot%20upload%20or%20drag%26amp%3Bdrop%20files%20(Bug)%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1771157%22%20slang%3D%22en-US%22%3E%3CP%3EWe%20are%20having%20the%20same%20issue%20-%20some%20document%20libraries%20work%20and%20others%20do%20not.%26nbsp%3B%20Do%20you%20know%20how%20we%20can%20get%20status%20on%20Case%20%2322216444%20since%20Microsoft%20is%20now%20aware%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1771232%22%20slang%3D%22en-US%22%3ERe%3A%20Document%20Library%20tab%3A%20Cannot%20upload%20or%20drag%26amp%3Bdrop%20files%20(Bug)%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1771232%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F828980%22%20target%3D%22_blank%22%3E%40pblbsyl%3C%2FA%3E%26nbsp%3B%3CBR%20%2F%3EThank%20you%20for%20confirming.%3CBR%20%2F%3E%3CBR%20%2F%3ECase%26nbsp%3B22216444%20is%20a%20case%20i%20have%20open%20with%20Microsoft%20support.%3CBR%20%2F%3E%3CBR%20%2F%3EThis%20case%20is%20very%20slow%20and%20unhelpful%2C%20that%20is%20why%20i%20raised%20the%20issue%20here%20in%20tech%20community.%20we%20need%20to%20find%20a%20way%20to%20escalate%20this%20bug%20to%20Microsoft%20and%20get%20them%20to%20act.%3CBR%20%2F%3E%3CBR%20%2F%3EIf%20you%20are%20curious%2C%20the%20status%20of%20my%20support%20ticket%20is%3A%3CBR%20%2F%3Esupport%20agent%20claims%20that%20Microsoft%20Product%20group%20are%20aware%20of%20this%20bug%20but%20for%20some%20reason%20need%20me%20to%20collect%20fiddler%20logs%20for%20them.....%20so%20i%20did%20that%20and%20sent%20them%20back.%20waiting%20for%20their%20reply.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1771334%22%20slang%3D%22en-US%22%3ERe%3A%20Document%20Library%20tab%3A%20Cannot%20upload%20or%20drag%26amp%3Bdrop%20files%20(Bug)%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1771334%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F499695%22%20target%3D%22_blank%22%3E%40alexrademeyer%3C%2FA%3E%26nbsp%3BI%20just%20opened%20a%20ticket%20with%20Microsoft%20this%20morning%20also.%26nbsp%3B%20Will%20keep%20you%20posted%20if%20I%20get%20any%20resolution.%26nbsp%3B%20Thanks%20for%20the%20update.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1773579%22%20slang%3D%22en-US%22%3ERe%3A%20Document%20Library%20tab%3A%20Cannot%20upload%20or%20drag%26amp%3Bdrop%20files%20(Bug)%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1773579%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F828980%22%20target%3D%22_blank%22%3E%40pblbsyl%3C%2FA%3E%26nbsp%3Bany%20update%20on%20your%20support%20ticket%3F%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20had%20an%20update%20on%20mine%20but%20it%20is%20not%20helpful%20(surprise!)%20%3A)%3C%2Fimg%3E%3C%2FP%3E%3CP%3Eon%20my%20side%2C%20I%20asked%20for%20some%20kind%20of%20post%20where%20customers%20can%20check%20the%20status%20of%20the%20bug%20(like%20we%20get%20in%20%3CA%20href%3D%22https%3A%2F%2Fadmin.microsoft.com%2FAdminportal%2FHome%23%2Fservicehealth%22%20target%3D%22_self%22%20rel%3D%22noopener%20noreferrer%22%3EService%20Health%3C%2FA%3E%20for%20example)%20and%20the%20support%20agent%20confirmed%20that%20Microsoft%20keeps%20bugs%26nbsp%3B%22confidential%22%20and%20do%20not%20share%20updates%20with%20customers.%20So%20he%20closed%20the%20ticket.%26nbsp%3B%3CBR%20%2F%3ETruly%20awful%20work%20by%20MS%20Support%2C%20as%20expected%3A%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20image-alt%3D%222020-10-13%2008_31_51-Inbox%20-%20alex.rademeyer%40tobii.com%20-%20Outlook.png%22%20style%3D%22width%3A%20400px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F226205i6EEF2C5967A8902B%2Fimage-size%2Fmedium%3Fv%3D1.0%26amp%3Bpx%3D400%22%20role%3D%22button%22%20title%3D%222020-10-13%2008_31_51-Inbox%20-%20alex.rademeyer%40tobii.com%20-%20Outlook.png%22%20alt%3D%222020-10-13%2008_31_51-Inbox%20-%20alex.rademeyer%40tobii.com%20-%20Outlook.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20hope%20you%20make%20better%20progress%20on%20your%20side.%3CBR%20%2F%3E%3CBR%20%2F%3EAlex%3C%2FP%3E%3CP%3E%E2%80%83%3C%2FP%3E%3CP%3E%3CBR%20%2F%3E%3CBR%20%2F%3E%3CBR%20%2F%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1775154%22%20slang%3D%22en-US%22%3ERe%3A%20Document%20Library%20tab%3A%20Cannot%20upload%20or%20drag%26amp%3Bdrop%20files%20(Bug)%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1775154%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F499695%22%20target%3D%22_blank%22%3E%40alexrademeyer%3C%2FA%3E%26nbsp%3B%3A%26nbsp%3B%20Just%20finished%20with%20my%20first%20support%20call.%26nbsp%3B%20No%20resolution%20so%20far%2C%20but%20he%20is%20escalating%20to%20the%20SharePoint%20team%20next.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EFor%20our%20configuration%2C%20the%20Teams%20upload%20is%20failing%20if%20the%20document%20library%20tab%20connects%20to%20a%20SharePoint%20document%20library%20that%20contains%20document%20sets%20with%20a%20default%20content%20type.%26nbsp%3B%20From%20within%20Teams%3A%3C%2FP%3E%3CUL%3E%3CLI%3EI%20cannot%20upload%20inside%20a%20document%20set.%3C%2FLI%3E%3CLI%3EI%20cannot%20upload%20outside%20of%20the%20document%20set%20at%20the%20top-level%20of%20the%20document%20library.%3C%2FLI%3E%3CLI%3EI%20cannot%20upload%20to%20a%20folder%20at%20the%20top-level%20of%20the%20document%20library.%3C%2FLI%3E%3C%2FUL%3E%3CP%3EIf%20I%20add%20a%20document%20library%20tab%20in%20Teams%20to%20just%20a%20simple%20document%20library%20in%20SharePoint%20with%20no%20document%20sets%2C%20etc.%2C%20then%20the%20upload%20is%20fine.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EIf%20your%20configuration%20and%20issue%20similar%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1832011%22%20slang%3D%22en-US%22%3ERe%3A%20Document%20Library%20tab%3A%20Cannot%20upload%20or%20drag%26amp%3Bdrop%20files%20(Bug)%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1832011%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F499695%22%20target%3D%22_blank%22%3E%40alexrademeyer%3C%2FA%3E%3CSPAN%3E%26nbsp%3B%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%3CSPAN%3EI%20continued%20to%20work%20with%20Microsoft%2C%20and%20yesterday%20I%20was%20able%20to%20upload%20to%20the%20Document%20Library%20tab%20with%20no%20errors.%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%3ECurious%20if%20this%20also%20works%20for%20you%20now%3F%26nbsp%3B%20I%20know%20it%20doesn't%20fix%20the%20corrupted%20files%20that%20are%20in%20place%2C%20but%20would%20be%20interested%20to%20see%20if%20new%20file%20uploads%20work%20now.%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%3EThanks!%3C%2FSPAN%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E
Occasional Contributor

Hi,

I have been running in circles with support and I am not getting anywhere, i need to raise my concern about a bug in MS Teams which causes your uploaded sharepoint files to be corrupt, and lose all contents.
I have reproduced this in 3 different tenants now, for multiple users and multiple computers, it absolutely is a bug.

 

The bug exists int he "document library" tab within a team and the repro steps are simple:

 

  • create a new or use an existing team.
  • add the "document library" app for any sharepoint library
  • in the teams client (web or desktop) drag&drop a file into this library.
  • teams gives an error: failed to upload file, "Please check if the site is available....."
  • the site is available, of course, you can still upload files into sharepoint directly.
  • the file which failed to upload be seen in sharepoint but IS CORRUPT AND CANNOT BE OPENED
    blob1601562024091.png

 

I raised this with support but as usual it is not going anywhere. they want to have a 3 hour call collecting HAR files and fiddler logs etc, and want to spend the next few weeks asking me about my laptop- no thanks.
Also raised it in uservoice but I doubt it will get any attention: 
https://microsoftteams.uservoice.com/forums/908686-bug-reports/suggestions/41580901-document-library...

 

If we as users find a bug (A bad 1... which affects all tenants and causes our files to become corrupt..... for example) HOW can we escalate these effectively? this is hopeless




 

 

 

17 Replies
Hey! I checked this in 2 tenants. I can not reproduce this behavior. Do you using a proxy? Checked with a direct internet connection without any between?

@TheM365Guy 

 

hi, thanks for being engaged.

I just tested again.
Today the error in the Teams client is gone.

However, the files that i uploaded are still corrupt (and this is the main issue).

If you check 1 of the files you uploaded via teams client, can you see the content?

 

For me, they all look like this:

 

2020-10-09 09_37_22-DOCX File viewer _ Microsoft Teams.png

 

Also, please make sure that the "document library" tab you added is to a sharepoint site (preferrably NOT the same site created by the team automatically.) i will say this: This bug does not exist on some libraries i tested, but for most of them, it does... if you could, can you please try libraries from a few different site collections? Honestly i can't identify which libraries are/are not affected but from what i have seen, most libraries are affected.

 

Oh! and to answer your question:
no, i am not using a proxy.
2 colleagues (both working from home) reproduced this yesterday, and so did a microsoft support agent, so i really dont think it is related to tenant, user, computer, network.

@alexrademeyer I did it like described. No issues, I can upload the files. I can access the files. Also I checked this now with 3 different document libraries. One with a team created library, two with some complete different SharePoint libraries, I can not reproduce this issue. 

Our tenant is based in EMEA, just as information. 

 

@TheM365Guy 

ok, thank you for taking the time to troubleshoot :)

I have tested in our Live tenant, my dev tenant, and also a microsoft support agent (in Asia somewhere) tested in his tenant- all 3 were affected.

Interesting to hear that yours are not.... this might help us get closer to an answer.

Thanks again.

Microsoft support have confirmed that the product team are aware of this bug:

alexrademeyer_0-1602485474281.png

 

Unfortunately i still don't see the bug documented anywhere...... service health, message center, here (besides my post) and the result is that customer files are becoming corrupt and customers are losing data.

 

so, back to my original post:
HOW are we supposed to raise bugs and product issues in an efficient way, how do we get Microsoft to admit and fix such issues.

 

We are having the same issue - some document libraries work and others do not.  Do you know how we can get status on Case #22216444 since Microsoft is now aware?

@pblbsyl 
Thank you for confirming.

Case 22216444 is a case i have open with Microsoft support.

This case is very slow and unhelpful, that is why i raised the issue here in tech community. we need to find a way to escalate this bug to Microsoft and get them to act.

If you are curious, the status of my support ticket is:
support agent claims that Microsoft Product group are aware of this bug but for some reason need me to collect fiddler logs for them..... so i did that and sent them back. waiting for their reply.

@alexrademeyer I just opened a ticket with Microsoft this morning also.  Will keep you posted if I get any resolution.  Thanks for the update.

@pblbsyl any update on your support ticket?

 

I had an update on mine but it is not helpful (surprise!) :)

on my side, I asked for some kind of post where customers can check the status of the bug (like we get in Service Health for example) and the support agent confirmed that Microsoft keeps bugs "confidential" and do not share updates with customers. So he closed the ticket. 
Truly awful work by MS Support, as expected:

 

2020-10-13 08_31_51-Inbox - alex.rademeyer@tobii.com - Outlook.png

 

I hope you make better progress on your side.

Alex




@alexrademeyer :  Just finished with my first support call.  No resolution so far, but he is escalating to the SharePoint team next.

 

For our configuration, the Teams upload is failing if the document library tab connects to a SharePoint document library that contains document sets with a default content type.  From within Teams:

  • I cannot upload inside a document set.
  • I cannot upload outside of the document set at the top-level of the document library.
  • I cannot upload to a folder at the top-level of the document library.

If I add a document library tab in Teams to just a simple document library in SharePoint with no document sets, etc., then the upload is fine.

 

If your configuration and issue similar?

@pblbsyl 

hi, thanks for keeping this issue updated, and for your information.
I also got my issue escalated today- it is escalated to the "product group"- unclear which product though. I await their reply.

 

Interesting note about document sets... thanks for confirming.
On this side however i have reproduced the issue on a site where the "document set" content type is not even enabled.
To answer clearly: I have this issue on document libraries which do not use document sets.

 

as a quick test i just did the following, which might be interesting for you to hear:
i created a brand new document library (no customisations, no document sets, and no documents. brand new).

This was created on the same site where other affected libraries are hosted. 
I added this new library to a team using the "document library" app.
Tried to upload a file here and got the same error.

 

Not sure what this tells me, but i think it is interesting to see the error on a brand new, empty library.

 

hope we get the answer soon.

Alex

@alexrademeyer I just ran across documentation of a method that does seem to work for me.

 

  1. In your Teams site, go to the Files tab.
  2. Click + Add cloud storage.
  3. Then choose SharePoint.
  4. Find your document library.
  5. The document library now shows as a folder in Files.
  6. Managed metadata is also available if you click into this folder.
  7. I am able to upload into this new "folder".

Let me know if that works for you also?  In my setup it is fine to ask the users to add this way as opposed to the Document Library tab.  So this may be a solution for us.  Would like to know if you also get good results.  Thanks!

 

 

 

 

@pblbsyl 
Thanks! I tested this and it is a good workaround.
Very nice, thank you for the suggestion.
I can announce this to my users but can't be sure they will all see it and/or stop using the "document library" app (which is still broken).
But i think this is a good workaround or temporary solution- nice thinking and thank you!

@alexrademeyer You are very welcome!  I am still waiting to hear back from my users, so thank you for letting me know this worked for you. 

 

Since my ticket has not been closed with Microsoft I will continue to pursue to see if they can figure out the issue.  Will let you know if they do.

 

Thanks!

@alexrademeyer 

I continued to work with Microsoft, and yesterday I was able to upload to the Document Library tab with no errors.

 

Curious if this also works for you now?  I know it doesn't fix the corrupted files that are in place, but would be interested to see if new file uploads work now.

 

Thanks!

@pblbsyl 
Hi, thanks for reaching out.
Interestingly, Microsoft reached out to me today and asked me to reproduce the issue again.
I tried but I can't - seems solved for me too!

I will test some more tomorrow but I suspect this is solved- thanks for sticking with this over the weeks!

Alex

best response confirmed by alexrademeyer (Occasional Contributor)
Solution

@pblbsyl 
I finally have a useful update from Microsoft.

This should likely close the issue off:

Microsoft acknowledge the bug and that their product team are rolling out a solution which should be out in the next few weeks:

alexrademeyer_0-1604054824079.png

 

 

Unfortunately this does not actually fix the damage done......
This bug corrupts customer data yet Microsoft have not acknowledged it in the message center or service updates.
Further: They have confirmed to me it is not possible to identify or restore the corrupt files- they will be lost.

 

I see this as "solved" in some way although i have lost a little more faith in Microsoft today- to me this is a business practice which does not encourage our trust. these kinds of bugs should be communicated.

 

Alex

 

www.000webhost.com