SOLVED

Direct Routing setup still not working or documented

%3CLINGO-SUB%20id%3D%22lingo-sub-2706587%22%20slang%3D%22en-US%22%3EDirect%20Routing%20setup%20still%20not%20working%20or%20documented%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2706587%22%20slang%3D%22en-US%22%3E%3CP%3EI%20am%20currently%20unable%20to%20add%20new%20users%20to%20our%20Direct%20Routing%20setup%20in%20MS%20Teams.%26nbsp%3B%20This%20is%20broken%20since%20the%20S4B%20module%20was%20deprecated.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ESome%20basics...%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20am%20running%20Powershell%20v5.1%3C%2FP%3E%3CP%3EI%20have%20installed%20module%20Microsoft%20Teams%20v2.5.1%3C%2FP%3E%3CP%3EI%20am%20'connected'%20to%20MicrosoftTeams%20module%20as%20a%20Global%20Admin%20who%20also%20has%20the%20S4B%20Admin%20role%20assigned%20(although%20it%20should%20need%20a%20separate%20role%20assignment).%3C%2FP%3E%3CP%3EI%20have%20'imported'%20the%20Microsoft%20Teams%20module%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20am%20trying%20to%20run%3A%3C%2FP%3E%3CP%3ESet-CsUser%20-Identity%20%22xxxxx%40yyyyy.org%22%20-OnPremLineURI%20tel%3A%2B44000000000%20-EnterpriseVoiceEnabled%20%24true%20-HostedVoiceMail%20%24true%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20receive%20back%3A%3C%2FP%3E%3CP%3ESet-CsUser%20%3A%20The%20'Set-CsUser'%20command%20was%20found%20in%20the%20module%20'MicrosoftTeams'%2C%20but%20the%20module%20could%20not%20be%20loaded.%20For%20more%20information%2C%20run%20'Import-Module%20MicrosoftTeams'%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EIf%20I%20try%3A%3C%2FP%3E%3CP%3ESet-CsOnlineVoiceUser%20-Identity%20%22xxxx%40yyyy.org%22%20-TelephoneNumber%20tel%3A%2B440000000000%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20receive%20back%3A%3C%2FP%3E%3CP%3ESet-CsOnlineVoiceUser%20%3A%20The%20'Set-CsOnlineVoiceUser'%20command%20was%20found%20in%20the%20module%20'MicrosoftTeams'%2C%20but%20the%20module%20could%20not%20be%20loaded.%20For%20more%20information%2C%20run%20'Import-Module%20MicrosoftTeams'%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E'Import-Module%20Microsoft%20Teams'%26nbsp%3B%20has%20already%20been%20run%20and%20running%20it%20again%20does%20not%20provide%20any%20additional%20information.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ENone%20of%20the%20cmdlet%20reference%20guides%20Microsoft%20have%20published%20even%20list%20the%20cmdlets%20from%20the%20S4B%20module%20that%20needed%20to%20be%20used%20for%20Enterprise%20Direct%20Routing%20so%20this%20leads%20me%20to%20ask...%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E1)%20When%20will%20Microsoft%20update%20the%20documentation%20for%20the%20new%20MicrosoftTeams%20module%20to%20include%20the%20full%20cmdlet%20list%3F%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E2)%20What%20commands%20'should'%20I%20be%20using%20to%20add%20users%20to%20our%20Direct%20Routing%20and%20to%20grant%20OnlineVoiceRoutingPolicy%20(s)%3F%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EMany%20thanks%20in%20advance%20to%20anyone%20who%20has%20the%20answers.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-2706587%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EDirect%20Routing%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EPowerShell%20CMDLETS%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3ETeams%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2706866%22%20slang%3D%22en-US%22%3ERe%3A%20Direct%20Routing%20setup%20still%20not%20working%20or%20documented%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2706866%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F291136%22%20target%3D%22_blank%22%3E%40Technodude%3C%2FA%3E%26nbsp%3BIt%20sounds%20like%20there%20is%20a%20problem%2C%20maybe%20a%20corruption%20in%20the%20module%20code%20on%20your%20machine.%20Try%20finding%20and%20deleting%20it%20before%20import-module%20again.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2707370%22%20slang%3D%22en-US%22%3ERe%3A%20Direct%20Routing%20setup%20still%20not%20working%20or%20documented%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2707370%22%20slang%3D%22en-US%22%3EHi%20Steven.%20Already%20tried%20that%20I'm%20afraid.%20..but%20thanks%20anyway%20%3A)%3C%2Fimg%3E%3C%2FLINGO-BODY%3E
Contributor

I am currently unable to add new users to our Direct Routing setup in MS Teams.  This is broken since the S4B module was deprecated.

 

Some basics...

 

I am running Powershell v5.1

I have installed module Microsoft Teams v2.5.1

I am 'connected' to MicrosoftTeams module as a Global Admin who also has the S4B Admin role assigned (although it should need a separate role assignment).

I have 'imported' the Microsoft Teams module

 

I am trying to run:

Set-CsUser -Identity "xxxxx@yyyyy.org" -OnPremLineURI tel:+44000000000 -EnterpriseVoiceEnabled $true -HostedVoiceMail $true

 

I receive back:

Set-CsUser : The 'Set-CsUser' command was found in the module 'MicrosoftTeams', but the module could not be loaded. For more information, run 'Import-Module MicrosoftTeams'

 

 

If I try:

Set-CsOnlineVoiceUser -Identity "xxxx@yyyy.org" -TelephoneNumber tel:+440000000000

 

I receive back:

Set-CsOnlineVoiceUser : The 'Set-CsOnlineVoiceUser' command was found in the module 'MicrosoftTeams', but the module could not be loaded. For more information, run 'Import-Module MicrosoftTeams'

 

'Import-Module Microsoft Teams'  has already been run and running it again does not provide any additional information.

 

None of the cmdlet reference guides Microsoft have published even list the cmdlets from the S4B module that needed to be used for Enterprise Direct Routing so this leads me to ask...

 

1) When will Microsoft update the documentation for the new MicrosoftTeams module to include the full cmdlet list?

 

2) What commands 'should' I be using to add users to our Direct Routing and to grant OnlineVoiceRoutingPolicy (s)?

 

Many thanks in advance to anyone who has the answers.

 

 

3 Replies

@Technodude It sounds like there is a problem, maybe a corruption in the module code on your machine. Try finding and deleting it before import-module again.

Hi Steven. Already tried that I'm afraid. ..but thanks anyway :)
best response confirmed by Technodude (Contributor)
Solution
Well... I logged a ticket with Microsoft at the same time as posting on here and they've been brilliant and got the issue resolved. So... for anyone reading this...

1) Microsoft are currently working on the documentation and hope to have it live soon.
2) The old CS- cmdlets are all included within the latest 2.5.1 module but... I had to do the following to resolve the issue....

Uninstall-Module MicrosoftTeams (to remove 2.5.1)
Install-Module MicrosoftTeams (without version number) ... this errored and came back telling me I had the MicrosoftTeams module v0.9.6 already installed and to use -force to sideload the 2.5.1 module.
Instead, I was asked to delete the v0.9.6 module from the location specified in the error message
Afterwards, re-ran Install-Module MicrosoftTeams and it installed without error.

Once installed I was able to run the CS- commands without issue. :)
www.000webhost.com