SOLVED

Create a Team from an existing Team - SharePoint site Error is this by design?

%3CLINGO-SUB%20id%3D%22lingo-sub-962204%22%20slang%3D%22en-US%22%3ECreate%20a%20Team%20from%20an%20existing%20Team%20-%20SharePoint%20site%20Error%20is%20this%20by%20design%3F%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-962204%22%20slang%3D%22en-US%22%3E%3CP%3EWe%20are%20seeing%20an%20error%20when%20you%20create%20a%20team%20from%20an%20existing%20team%20and%20click%20on%20any%20channel%20%26gt%3B%20Open%20in%20SharePoint.%20At%20first%20I%20thought%20that%20something%20was%20not%20working%2C%20but%20then%20I%20tested%20further%20by%20adding%20a%20document%20in%20a%20channel%20and%20then%20clicking%20%26gt%3B%20Open%20in%20SharePoint%20and%20the%20URL%20to%20SharePoint%20worked.%20I'd%20like%20to%20know%20if%20this%20is%20by%20design%26nbsp%3Bsince%20in%20theory%20when%20you%20copy%20a%26nbsp%3BTeam%20the%26nbsp%3Bcontent%20doesn't%20come%20over.%20Can%20someone%20confirm%3F%20%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F169605%22%20target%3D%22_blank%22%3E%40Christopher%20Hoard%3C%2FA%3E%26nbsp%3Bwould%20you%20happen%20to%20know%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-962204%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EMicrosoft%20Teams%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3ESharePoint%20Site%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-962215%22%20slang%3D%22en-US%22%3ERe%3A%20Create%20a%20Team%20from%20an%20existing%20Team%20-%20SharePoint%20site%20Error%20is%20this%20by%20design%3F%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-962215%22%20slang%3D%22en-US%22%3E%3CP%3EHi%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F815%22%20target%3D%22_blank%22%3E%40Lillian%20Diaz%3C%2FA%3E%20%2C%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThe%20tabs%20are%20copied%20but%20the%20Tabs%20are%20not%20setup%20to%20point%20to%20the%20correct%20location%2C%20you%20have%20to%20go%20through%20each%20tab%20and%20set%20it%20up%20again.%20A%20bit%20of%20a%20half%20thought%20out%20function%20if%20you%20ask%20me%20as%20it%20isnt%20really%20a%20copy%20as%20you%20cannot%20use%20it%20once%20copied.%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EWe%20just%20did%20a%20project%20where%20we%20wrote%20some%20powershell%20using%20an%20Azure%20App%20and%20the%20Graph%20API%20to%20do%20this%20properly.%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EHope%20that%20helps%3C%2FP%3E%3CP%3E%3CBR%20%2F%3EAndy%3C%2FP%3E%3C%2FLINGO-BODY%3E
Regular Contributor

We are seeing an error when you create a team from an existing team and click on any channel > Open in SharePoint. At first I thought that something was not working, but then I tested further by adding a document in a channel and then clicking > Open in SharePoint and the URL to SharePoint worked. I'd like to know if this is by design since in theory when you copy a Team the content doesn't come over. Can someone confirm? @Christopher Hoard would you happen to know?

1 Reply
best response confirmed by Lillian Diaz (Regular Contributor)
Solution

Hi@Lillian Diaz ,

 

The tabs are copied but the Tabs are not setup to point to the correct location, you have to go through each tab and set it up again. A bit of a half thought out function if you ask me as it isnt really a copy as you cannot use it once copied. 

 

We just did a project where we wrote some powershell using an Azure App and the Graph API to do this properly. 

 

Hope that helps


Andy

www.000webhost.com