Can't log on to microsoft teams on my pc

%3CLINGO-SUB%20id%3D%22lingo-sub-1336993%22%20slang%3D%22en-US%22%3ECan't%20log%20on%20to%20microsoft%20teams%20on%20my%20pc%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1336993%22%20slang%3D%22en-US%22%3E%3CP%3EI%20can%20log%20on%20to%20ms%20teams%20on%20someone%20else's%20computer%20just%20fine.%20But%20when%20i%20try%20to%20log%20on%20teams%20on%20my%20pc%2C%20the%20application%20says%20%22weve%20ran%20into%20an%20issue%20try%20again%2C%20if%20that%20doesn't%20work%20sign%20out%20and%20try%20again%22%20i%20also%20tried%20signing%20onto%20the%20browser%20and%20it%20didnt%20work%20but%20im%20more%20focused%20on%20the%20application.%20I%20already%20tried%20restarting%20pc%2C%20uninstalling%20and%20reinstalling%20teams%2C%20and%20signing%20out%20and%20signing%20back%20in%20and%20nothing%20worked.%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-1336993%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EMicrosoft%20Teams%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1337167%22%20slang%3D%22en-US%22%3ERe%3A%20Can't%20log%20on%20to%20microsoft%20teams%20on%20my%20pc%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1337167%22%20slang%3D%22en-US%22%3EUninstall%20the%20Application%2C%20then%20clear%20the%20cache!%20%3CBR%20%2F%3EAlso%20just%20in%20case%20go%20to%20install%20did%20and%20manually%20delete%20what%E2%80%99s%20left.%20%3CBR%20%2F%3ERe-install%3CBR%20%2F%3E%3CBR%20%2F%3ERegarding%20web%20client%2C%20try%20a%20private%20browser%20session.%3C%2FLINGO-BODY%3E
Occasional Visitor

I can log on to ms teams on someone else's computer just fine. But when i try to log on teams on my pc, the application says "weve ran into an issue try again, if that doesn't work sign out and try again" i also tried signing onto the browser and it didnt work but im more focused on the application. I already tried restarting pc, uninstalling and reinstalling teams, and signing out and signing back in and nothing worked. 

1 Reply
Uninstall the Application, then clear the cache!
Also just in case go to install did and manually delete what’s left.
Re-install

Regarding web client, try a private browser session.
www.000webhost.com