Security assessment: Microsoft LAPS usage

%3CLINGO-SUB%20id%3D%22lingo-sub-1935973%22%20slang%3D%22en-US%22%3ESecurity%20assessment%3A%20Microsoft%20LAPS%20usage%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1935973%22%20slang%3D%22en-US%22%3E%3CP%3EWe%20have%20had%20LAPS%20in%20our%20environment%20for%20a%20number%20of%20months%20now%2C%20but%20we%20have%202%20issues%20with%20the%20LAPS%20usage%20assessment%3A%3CBR%20%2F%3E%3CBR%20%2F%3E1.%20Duplicate%20device%20entries%20-%20we%20have%20around%20100%20devices%20with%202%20or%20sometime%203%20entries%20in%20the%20report.%3CBR%20%2F%3E2.%20Data%20doesn't%20seem%20up%20to%20date%20-%20we%20have%20devices%20reported%20as%20'LAPS%20is%20not%20deployed'%20when%20the%20LAPS%20attributes%20were%20updated%20some%20weeks%20ago.%20I%20believe%20from%20the%20documentation%20that%20the%20LAPS%20assessment%20should%20run%20every%2024%20hours.%3CBR%20%2F%3E%3CBR%20%2F%3ECan%20anyone%20suggest%20causes%2Ffixes%20for%20these%20issues%3F%3CBR%20%2F%3E%3CBR%20%2F%3EMany%20Thanks%2C%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EStuart.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1938341%22%20slang%3D%22en-US%22%3ERe%3A%20Security%20assessment%3A%20Microsoft%20LAPS%20usage%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1938341%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F736246%22%20target%3D%22_blank%22%3E%40StuartSquibb%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EHi%2C%3C%2FP%3E%0A%3CP%3E1.%20Regarding%20the%20duplicated%20devices%2C%20can%20you%20confirm%20these%20are%20the%20same%20devices%2C%20not%20devices%20from%20other%20domains%20or%20that%20have%20been%20deleted%3F%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3E2.%20If%20you%20are%20certain%20that%20these%20specific%20devices%20are%20indeed%20LAPS%20deployed%2C%20please%20open%20a%20support%20ticket%20as%20this%20needs%20to%20be%20verified.%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EThanks!%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1938344%22%20slang%3D%22en-US%22%3ERe%3A%20Security%20assessment%3A%20Microsoft%20LAPS%20usage%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1938344%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F736246%22%20target%3D%22_blank%22%3E%40StuartSquibb%3C%2FA%3E%26nbsp%3B%2C%20for%20the%20device%20reported%20as%20%22laps%20is%20not%20deployed%22%2C%20can%20you%20check%20the%20value%20of%20the%26nbsp%3Bms-Mcs-AdmPwdExpirationTime%20attribute%3F%20is%20it%20older%20than%2060%20days%20%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1941213%22%20slang%3D%22en-US%22%3ERe%3A%20Security%20assessment%3A%20Microsoft%20LAPS%20usage%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1941213%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F215466%22%20target%3D%22_blank%22%3E%40Or%20Tsemah%3C%2FA%3E%3CBR%20%2F%3EHaving%20spent%20some%20time%20digging%20around%20in%20our%20on-prem%20environment%2C%20it%20looks%20as%20if%20these%20are%20objects%20the%20have%20been%20tombstoned%20in%20our%20AD%2C%20probably%20with%20the%20devices%20in%20question%20having%20been%20rebuilt%20multiple%20times%2C%20so%20this%20was%20a%20false%20alarm%2C%20sorry%20for%20wasting%20your%20time%20%3CIMG%20class%3D%22lia-deferred-image%20lia-image-emoji%22%20src%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Fhtml%2Fimages%2Femoticons%2Ffacepalm_40x40.gif%22%20alt%3D%22%3Afacepalm%3A%22%20title%3D%22%3Afacepalm%3A%22%20%2F%3E.%3CBR%20%2F%3E%3CBR%20%2F%3EWould%20it%20be%20at%20all%20possible%20to%20surface%20the%20DeviceObjectId%20property%20of%20devices%20in%20the%20downloadable%20versions%20of%20the%20LAPS%20reports%3F%20This%20would%20really%20help%20us%20in%20reconciling%20the%20data%2C%20as%20it%20is%20a%20common%20identifier%20between%20on-prem%20AD%2C%20Azure%20AD%20and%20MDI%2FMCAS.%3CBR%20%2F%3E%26nbsp%3B%3C%2FP%3E%3CP%3EOnce%20again%2C%20my%20apologies%20for%20the%20false%20alarm.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EStuart.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1943822%22%20slang%3D%22en-US%22%3ERe%3A%20Security%20assessment%3A%20Microsoft%20LAPS%20usage%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1943822%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F736246%22%20target%3D%22_blank%22%3E%40StuartSquibb%3C%2FA%3E%26nbsp%3BNo%20worries%20Stuart%2C%3C%2FP%3E%0A%3CP%3EWe%20are%20constantly%20evaluating%20how%20to%20better%20surface%20the%20information%20presented%20in%20the%20assessments%2C%20so%20I'll%20add%20you're%20suggestion%20to%20the%20list%20and%20update%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E
Occasional Contributor

We have had LAPS in our environment for a number of months now, but we have 2 issues with the LAPS usage assessment:

1. Duplicate device entries - we have around 100 devices with 2 or sometime 3 entries in the report.
2. Data doesn't seem up to date - we have devices reported as 'LAPS is not deployed' when the LAPS attributes were updated some weeks ago. I believe from the documentation that the LAPS assessment should run every 24 hours.

Can anyone suggest causes/fixes for these issues?

Many Thanks,

 

Stuart.

8 Replies

@StuartSquibb 

Hi,

1. Regarding the duplicated devices, can you confirm these are the same devices, not devices from other domains or that have been deleted?

 

2. If you are certain that these specific devices are indeed LAPS deployed, please open a support ticket as this needs to be verified.

 

Thanks!

@StuartSquibb , for the device reported as "laps is not deployed", can you check the value of the ms-Mcs-AdmPwdExpirationTime attribute? is it older than 60 days ?

@Or Tsemah
Having spent some time digging around in our on-prem environment, it looks as if these are objects the have been tombstoned in our AD, probably with the devices in question having been rebuilt multiple times, so this was a false alarm, sorry for wasting your time :facepalm:.

Would it be at all possible to surface the DeviceObjectId property of devices in the downloadable versions of the LAPS reports? This would really help us in reconciling the data, as it is a common identifier between on-prem AD, Azure AD and MDI/MCAS.
 

Once again, my apologies for the false alarm.

 

Stuart.

@StuartSquibb No worries Stuart,

We are constantly evaluating how to better surface the information presented in the assessments, so I'll add you're suggestion to the list and update

 

@Or Tsemah

 

Hopefully its OK that I jump on this thread.

I have been looking at the LAPS reports this morning and wonder if its possible to get some more fields addded?

A lot of the machines in the report are either disabled or deleted (tombstoned) in AD. I don't see any point in following them up, so it would be good if we could filter them out.

It would also be useful to see if the machine is active or not.  Could you add lastLogonTimestamp (the replicated one) so we can see if the machine is worth following up?
Best regards,

Sandy

@SandyMc 

Thanks for those suggestion, these are indeed items that we would like to see in the report and we are actively working on making these happen, I'll share an ETA when i have on

Any ETA on this? Could be a good help for us

@PELADANISHAGRO No ETA regarding the added columns, however, tombstoned devices should already be excluded, ping me if they are not

www.000webhost.com