SOLVED

MDI Sensor stopped communicating

Occasional Contributor

Hello,

 

We have two sensors running on RODC  which stopped communicating recently, So we uninstalled the old sensor and installed the new sensor from MDI portal package. Now after reinstallation we see that the Sensor and Updater are in running state from RODC but in MDI portal we still see they are in Disconnected state.

 

Microsoft.Tri.Sensor-Errors: 

 

2022-03-24 15:03:39.9574 Error ConcurrentDictionary`2 System.Collections.Generic.KeyNotFoundException: The given key was not present in the dictionary.
at TValue System.Collections.Concurrent.ConcurrentDictionary<TKey, TValue>.get_Item(TKey key)
at void Microsoft.Tri.Sensor.DomainControllerConnectionPool.Return(CacheEntry<Guid, DomainControllerConnection> entry)+(Guid key) => { }
at bool System.Linq.Enumerable+WhereSelectListIterator<TSource, TResult>.MoveNext()
at bool System.Linq.Enumerable+WhereEnumerableIterator<TSource>.MoveNext()
at new System.Collections.Generic.List<T>(IEnumerable<T> collection)
at List<TSource> System.Linq.Enumerable.ToList<TSource>(IEnumerable<TSource> source)
at void Microsoft.Tri.Sensor.DomainControllerConnectionPool.Return(CacheEntry<Guid, DomainControllerConnection> entry)
at async Task<IReadOnlyCollection<DirectoryServicesSearchResult>> Microsoft.Tri.Sensor.DirectoryServicesClient.SearchObjectsInternalAsync(Guid connectionKey, DistinguishedName baseDistinguishedName, SearchScope scope, string filter, string[] attributeNames, DirectoryServicesSearchOptions options)
at async Task<IReadOnlyCollection<DirectoryServicesSearchResult>> Microsoft.Tri.Sensor.DirectoryServicesClient.SearchObjectsAsync(Guid connectionKey, DistinguishedName baseDistinguishedName, SearchScope scope, string filter, string[] attributeNames, DirectoryServicesSearchOptions options)
at async Task<DirectoryServicesSearchResult> Microsoft.Tri.Sensor.DirectoryServicesClient.SearchObjectAsync(Guid connectionKey, DistinguishedName baseDistinguishedName, SearchScope scope, string filter, string[] attributeNames, DirectoryServicesSearchOptions options)
at async Task<SecurityPrincipal> Microsoft.Tri.Sensor.DirectoryServicesResolver.CreateSecurityPrincipalAsync(DistinguishedName distinguishedName, Domain domain, MultiKey<ComposedKey> additionalKey, IDictionary<DomainResourceName, string> accountResourceNameToIdMapping, IDictionary<DistinguishedName, string> securityPrincipalDistinguishedNameToIdMapping, IDictionary<SecurityIdentifier, string> securityPrincipalSidToIdMapping, DirectoryServicesSearchOptions options, Nullable<Guid> domainControllerConfigurationGuid)
at async Task<Account> Microsoft.Tri.Sensor.DirectoryServicesResolver.GetAccountSyncedAsync(DomainSecurityPrincipalName name, Domain domain, MultiKey<ComposedKey> accountKey)
at void Microsoft.Tri.Infrastructure.Syncer<T, TResult>+<>c__DisplayClass1_0+<<RunAsync>g__RunFunctionAsync|0>d.MoveNext()
at async ValueTask<Account> Microsoft.Tri.Sensor.DirectoryServicesResolver.GetAccountAsync(DomainSecurityPrincipalName name)
at async Task<IReadOnlyCollection<DomainControllerData>> Microsoft.Tri.Sensor.DirectoryServicesResolver.GetDomainControllerDatasAsync()
2022-03-24 15:03:39.9887 Error ConcurrentDictionary`2 Error adding domain [domainDistinguishedName=DC=Saskferco,DC=net]
System.Collections.Generic.KeyNotFoundException: The given key was not present in the dictionary.
at TValue System.Collections.Concurrent.ConcurrentDictionary<TKey, TValue>.get_Item(TKey key)
at void Microsoft.Tri.Sensor.DomainControllerConnectionPool.Return(CacheEntry<Guid, DomainControllerConnection> entry)+(Guid key) => { }
at bool System.Linq.Enumerable+WhereSelectListIterator<TSource, TResult>.MoveNext()
at bool System.Linq.Enumerable+WhereEnumerableIterator<TSource>.MoveNext()
at new System.Collections.Generic.List<T>(IEnumerable<T> collection)
at List<TSource> System.Linq.Enumerable.ToList<TSource>(IEnumerable<TSource> source)
at void Microsoft.Tri.Sensor.DomainControllerConnectionPool.Return(CacheEntry<Guid, DomainControllerConnection> entry)
at async Task<IReadOnlyCollection<DirectoryServicesSearchResult>> Microsoft.Tri.Sensor.DirectoryServicesClient.SearchObjectsInternalAsync(Guid connectionKey, DistinguishedName baseDistinguishedName, SearchScope scope, string filter, string[] attributeNames, DirectoryServicesSearchOptions options)
at async Task<IReadOnlyCollection<DirectoryServicesSearchResult>> Microsoft.Tri.Sensor.DirectoryServicesClient.SearchObjectsAsync(Guid connectionKey, DistinguishedName baseDistinguishedName, SearchScope scope, string filter, string[] attributeNames, DirectoryServicesSearchOptions options)
at async Task<IReadOnlyCollection<DirectoryServicesSearchResult>> Microsoft.Tri.Sensor.DirectoryServicesClient.SearchConfigurationObjectsAsync(Guid connectionKey, SearchScope scope, string filter, string[] attributeNames, DistinguishedName distinguishedNamePrefix, DirectoryServicesSearchOptions options)
at async Task<DirectoryServicesSearchResult> Microsoft.Tri.Sensor.DirectoryServicesClient.SearchConfigurationObjectAsync(Guid connectionKey, SearchScope scope, string filter, string[] attributeNames, DistinguishedName distinguishedNamePrefix)
at async Task<Domain> Microsoft.Tri.Sensor.DirectoryServicesResolver.CreateDomainAsync(DistinguishedName distinguishedName, Guid domainControllerConfigurationGuid)
at async Task Microsoft.Tri.Sensor.DirectoryServicesResolver.AddDomainAsync(DistinguishedName domainDistinguishedName, Guid connectionKey)

2 Replies
best response confirmed by Mazhar1675 (Occasional Contributor)
Solution
This specific error does not seem related to the described issue.
Can you verify in the portal that you don't see 2 sensors with the same name, one is running and the older one is disconnected by any chance ?

If not, I suggest to open a support case where you can securely upload the sensor's full textual log for inspection. make sure to include workspace id and sensor machine name.
Thanks @Eli Ofek, As you said there was duplicate server name in the list, so deleted the older one. While for other server followed the Win2019 troubleshooting mechanism. Now both the sensors are in running state.
www.000webhost.com