@TamasKosarszki 

What was the error message during the ping from Branch office?

"Request timed out."

 

What is the result, when you start a ping from App server to Branc office?

Hmm, I might have missed that test case ... actually I get "Request timed out" from App server towards Branch computer.

Main server and Win10 client is ok towards Branch computer.

 

Did you add static route rule to windows route table before (maybe it try to send respond on wrong gateway)? 

I do have basic skills in network, but when it comes to "static route rule", I'm kind of lost.

I really don't get why the Main server and clients works but this single server don't.

One finding here (thanks to you) is that the App server seems to be dead in both directions:

- From Branch to App Server

- From App Server to Branch

"Static Route rule" can you guide me on where to add that?

I really don't get why this server should be different from the other WS2019 (Main) server?

 

You mentioned already tried without firewall. Did you disabled all three firewall profile? 

Yes. Tried it ones more now. Doesn't help.

 

I really appreciate your feedback and help! By asking questions and challange we/I might find the issue. Right now I have Googled all Internet and have no more ideas. Very frustrating, I need to get it fixed.

 

Summary:

- Site-to-Site IPSEC VPN with two subnets.

- Branch computer is not domain connected, it can still ping other computers in Main office.

- Branch computer can ping both Main server and Win 10 client...

- ...but not the App server.

- App server can not ping Branch computer.

- App server can be pinged locally within Main office, no issues as long as the VPN tunnel isn't involved.

 

Big thanks for all help I can get!

 

EDIT:

From Branch computer I can ping Main office router (LAN IP).

From App server I cannot ping router (LAN IP) on Branch side!

From other computer within Main office, I can ping Branch router (LAN IP).

 

br

/MH

www.000webhost.com