I am having the same problem while trying to open Sticky Notes. I mean, I had a lot of notes there and I never bothered to sysc them to the cloud (firstly because the laptop is not personal, it's from the company where I work).

 

First I had (and still have btw) a problem where I couldn't open the start menu, but I tried many things and they work one time only and then they stop working at all.
when I am able to get the UI working correctly and I open Sticky Notes I get that error (The specified...).

 

I also tried exporting the Sticky Notes store file, but no luck, I can't even find the folder (and is not because is hidden) there just isn't any folder that contais that store file.

 

the worst thing is I had a buch of notes ONLY on sticky notes for quite a while and I planned to use/read all of them today on a meeting but this frick started happening yesterday (after I tried to do tricks with RDP/RDC) so I wasn't able to tell jack shift.

 

so far I had no luck...

 

ftr, my OS is W10 v1803

www.000webhost.com