Contributor

Hi,

 

I have a message extension app and it is working in the compose box but when we execute the app using @<appname>, it's getting a blank popup and does not show any results. I just tried with a simple hello world example was working fine before but now it's not working. I checked both in firefox and chrome and have the same issue. I couldn't change anything in the code. Could you please check the issue? What may be the reason? I have attached the screenshots

 

Screenshots

 

extension popup issue.png

message extension warnings.png

Manifest.json file

 

 

{
    "$schema": "https://developer.microsoft.com/en-ushttps://techcommunity.microsoft.com/json-schemas/teams/v1.11/MicrosoftTeams.schema.json",
    "manifestVersion": "1.11",
    "version": "1.0.1",
    "id": "4c146fc3-913f-45ae-9e89-579e71f6e65f",
    "packageName": "com.contoso.helloworld",
    "developer": {
        "name": "Contoso",
        "websiteUrl": "https://www.microsoft.com",
        "privacyUrl": "https://www.microsoft.com/privacy",
        "termsOfUseUrl": "https://www.microsoft.com/termsofuse"
    },
    "icons": {
        "color": "color.png",
        "outline": "outline.png"
    },
    "name": {
        "short": "Hello World1",
        "full": "Hello World App for Microsoft Teams"
    },
    "description": {
        "short": "Hello World App for Microsoft Teams",
        "full": "This sample app provides a very simple app for Microsoft Teams. You can extend this to add more content and capabilities."
    },
    "accentColor": "#60A18E",
    "configurableTabs": [
        {
            "configurationUrl": "https://yourteamsapp.ngrok.io/configure",
            "canUpdateConfiguration": true,
            "scopes": [
                "team"
            ]
        }
    ],
    "staticTabs": [
        {
            "entityId": "conversations",
            "scopes": [
                "personal"
            ]
        },
        {
            "entityId": "com.contoso.helloworld.hellotab",
            "name": "Hello Tab",
            "contentUrl": "https://969c766a5f65.ngrok.io/hello",
            "scopes": [
                "personal"
            ]
        },
        {
            "entityId": "about",
            "scopes": [
                "personal"
            ]
        }
    ],
    "bots": [
        {
            "botId": "2d92faff-b46b-4416-8ad3-ab7b5149e386",
            "scopes": [
                "personal",
                "team"
            ],
            "supportsFiles": false,
            "isNotificationOnly": false
        }
    ],
    "composeExtensions": [
        {
            "botId": "2d92faff-b46b-4416-8ad3-ab7b5149e386",
            "canUpdateConfiguration": false,
            "commands": [
                {
                    "id": "getRandomText",
                    "type": "query",
                    "title": "Get some random text for fun",
                    "description": "Gets some random text and images that you can insert in messages for fun.",
                    "initialRun": true,
                    "fetchTask": false,
                    "parameters": [
                        {
                            "name": "cardTitle",
                            "title": "Card title",
                            "description": "Card title to use",
                            "inputType": "text"
                        }
                    ]
                }
            ]
        }
    ],
    "permissions": [
        "identity",
        "messageTeamMembers"
    ],
    "validDomains": [
        "yourteamsapp.ngrok.io",
        "969c766a5f65.ngrok.io"
    ]
}

 

 

It seems related to this issue - https://github.com/MicrosoftDocs/msteams-docs/issues/4425

We have internal bug raised for this and concerned team is working on it.

Thanks

@HunaidHanfee-MSFT, Thanks for the update. I hope the issue will be fixed soon.

We support Ukraine and condemn war. Push Russian government to act against war. Be brave, vocal and show your support to Ukraine. Follow the latest news HERE