Hi@Nikitha-MSFT & @BeerStud 

 

I have just spent the afternoon attempting to get the Linux version (binary extracted from an RPM) on FreeBSD thanks to the FreeBSD kernels "Linux Compatibility" emulation.

 

I found that a large number of shared objects were not present, so I copied them over from a Linux installation that I have which runs the Linux version of Teams.

 

However, even once all the dependencies where satisfied, I still had these errors in the log:

/usr/home/cam/Downloads/teams/usr/share/teams/teams: /lib64/libm.so.6: version `GLIBC_2.29' not found (required by /usr/home/cam/Downloads/teams/usr/share/teams/./libpixman-1.so.0)
/usr/home/cam/Downloads/teams/usr/share/teams/teams: /lib64/libm.so.6: version `GLIBC_2.29' not found (required by /usr/home/cam/Downloads/teams/usr/share/teams/./libpng16.so.16)
/usr/home/cam/Downloads/teams/usr/share/teams/teams: /lib64/libc.so.6: version `GLIBC_2.25' not found (required by /usr/home/cam/Downloads/teams/usr/share/teams/./libsystemd.so.0)
/usr/home/cam/Downloads/teams/usr/share/teams/teams: /lib64/libc.so.6: version `GLIBC_2.28' not found (required by /usr/home/cam/Downloads/teams/usr/share/teams/./libsystemd.so.0)
/usr/home/cam/Downloads/teams/usr/share/teams/teams: /lib64/libc.so.6: version `GLIBC_2.26' not found (required by /usr/home/cam/Downloads/teams/usr/share/teams/./libsystemd.so.0)
/usr/home/cam/Downloads/teams/usr/share/teams/teams: /lib64/libc.so.6: version `GLIBC_2.30' not found (required by /usr/home/cam/Downloads/teams/usr/share/teams/./libsystemd.so.0)
/usr/home/cam/Downloads/teams/usr/share/teams/teams: /lib64/libc.so.6: version `GLIBC_2.27' not found (required by /usr/home/cam/Downloads/teams/usr/share/teams/./libsystemd.so.0)
/usr/home/cam/Downloads/teams/usr/share/teams/teams: /lib64/libc.so.6: version `GLIBC_2.25' not found (required by /usr/home/cam/Downloads/teams/usr/share/teams/./libgnutls.so.30)
/usr/home/cam/Downloads/teams/usr/share/teams/teams: /lib64/libc.so.6: version `GLIBC_2.25' not found (required by /usr/home/cam/Downloads/teams/usr/share/teams/./libbsd.so.0)
/usr/home/cam/Downloads/teams/usr/share/teams/teams: /lib64/libc.so.6: version `GLIBC_2.26' not found (required by /usr/home/cam/Downloads/teams/usr/share/teams/./libp11-kit.so.0)

 

I think a possible solution here would be to release a Linux portable version (unpack and execute) this would allow users of other non Debian or Red Hat based systems such as Arch to use Teams, and it would more than likely work for the various BSD Unix's as well

 

Cheers,

Cam

www.000webhost.com