I believe I may have found the issue, according to https://technet.microsoft.com/en-us/library/mt790552.aspx the Logitech Group only supports version 8.5.778 but my Group is running version 8.5.808 – are you able to confirm what version you are running? @Eric Iversen