AllowCloudRecordingForCalls is enabled for the Global policy. However, all our users were assigned a the policy "AllowCalling" which didn't have AllowCloudRecordingForCalls enabled. We weren't aware. It's fixed now. Thanks for the quick help.
www.000webhost.com