@Juan Carlos González Martín This was just solved by enabling a new (for me) property in Snagit - or at least its a workaround. In the Snagit editor preferences, go to "Share" and chose "Clipboard". Now you should see an option to disable image transparency on clipboard.

We support Ukraine and condemn war. Push Russian government to act against war. Be brave, vocal and show your support to Ukraine. Follow the latest news HERE