Occasional Contributor



I am on a Mac, using Chrome and/or the Teams App (it's the same issue in both).


My Microsoft Teams is stuck on "Getting your Class Notebook ready..."


I've created a Team, but when I try to create the notebook... it just gets stuck.


The frustrating part is that I created my class, and notebook, yesterday. It worked fine, then. Then I deleted it and started again... and now it won't work.


Is anyone else having this issue? I've tried restarting the App and the browser. I've logged out of Teams and O365. I've restarted my computer, cleared my browsing data/cookies, stopped the processes and restarted in Activity Monitor etc... I can't see the solution. 


Is there a solution (I'm frustrated as it was all working perfectly yesterday - and I deleted it!)




Screen Shot 2017-07-22 at 11.49.54 PM.png

I am having the same issue. An answer would be helpful!

best response confirmed by Jenny Malone (Occasional Contributor)

Hi Jenny,


After a couple  of rather frustrating phone calls and online chats regarding the same problem, as we were experiencing it too, one of the techs suggested it might have something to do with an issue they were having with OneNote online. It seems as though this may have been the case as all of a sudden yesterday, things started working again. That said any notebooks created through teams and stuck on that getting ready page, don't look like they are ever going to complete, and you may need to recreate the team :-/. Additionally for testing purposes I'd added a user to a Team with an embedded notebook and that user never duplicated to OneNote. Today, removing that user and readding them to the Team correctly added the user to OneNote as well.


Probably the most frustrating thing apart from it not working is that without exception, not a single person contacted through the official support channels, had no idea what Teams was. One of the support techs recommended I speak to someone in the Office Home support section. Obviously a crazy idea seeing as Teams isn't part of the home offering.


The TLDR version...it appears the link between Teams and OneNote was broken for around 48 hours, just not sure how widespread the issue was.





Thanks, Paul. Another user here, and our IT Team spent time on the phone with MS working through it on Monday and Tuesday, also... making their way through the "chain of command" until it was worked out too. 


Yes, it did seem there was an issue there that was affecting everyone, but has now been sorted, thank goodness! It's been a learning curve for us all. It just happened to 'happen' as we were rolling out across our Prep-12 College - after a small team of us had been trialling it for ages, with no issues! 


It's always the way!


Thanks again, for updating with your experience too. It's helpful to know it wasn't just us!



Hopefully it's sorted for you now too, James.

Im having the same issue - I also cannot open previously created class notebooks through team. any solution?

I am still having the same problem. I am surprise to see the problem exist since 2017. Any help? 

Hi Deric,

The issue that Jenny and I had seemed tied to a point in time issue with Office 365. That resolved it self for us within 24 hours or so. I can't speak for Jenny but we as an organisation haven't had the same problem occur since. If your problem is exactly the same, I'd suggest contacting Microsoft and see if they can shed any light. Otherwise if you post back here with more details, I can try and help, or someone else in the community might have some more information.


Latina, insightful! Your argument is profound and offered a point of view I had not yet considered and I would like to hear more and possibly subscribe to your newsletter and/or blog. :)





Thanks for the reply! 


There is no quick solution. I have to delete the entire team and recreate the team again.

I really hope this will not happen again. Please let me know if there is a solution to this