Occasional Contributor

Currently using Teams free.

We have been using teams for 6 months (17 members), the last 2 days I have been experiencing the following issues.

Description: I am unable to Invite people to join ORG in Teams. The last 3 people I have tried to add have the following error message: You don't have access to GWI Engineering. Contact your admin for more info.

Invites were sent though email, each user created a new Microsoft account.  See error message (image 1) below.

I login to sharepoint as an owner and I can see the members who were invited. See image 2. When I click on the members on the group, the icon spins and doesn't show a result.

So I do another test. I make a fake Microsoft account and invite this user to my Microsoft team - same error page results. I login to the Sharepoint site as this user and I can see the site, pages and members.

Again, I am using free teams.  Is anyone else experiencing this issue?


Any help is appreciated.

Thanks for you time.

If you can reliably reproduce this, open a support case.

@Vasil Michev 

Thanks for the reply, can you tell me where I can post this to support for Teams free?

Thanks, Chris

We have Teams set up so any member or our org can send invites so I'm not sure why the became an issue. I have invited all the other users in the past, just an fyi.


Another employee here is Admin for our Teams free. I can't find a location to change the Admin role to myself so this is what I did to add members.


Accessed the admin account, removed the users who were invited and resent a link by email to each of them. They were able to login to our org after this and access Teams.


Just an fyi for others if you have a similar issue. If someone finds a Microsoft site that supports Teams free, please leave a reply.


We support Ukraine and condemn war. Push Russian government to act against war. Be brave, vocal and show your support to Ukraine. Follow the latest news HERE