Occasional Contributor

Currently using Teams free.

We have been using teams for 6 months (17 members), the last 2 days I have been experiencing the following issues.

Description: I am unable to Invite people to join ORG in Teams. The last 3 people I have tried to add have the following error message: You don't have access to GWI Engineering. Contact your admin for more info.

Invites were sent though email, each user created a new Microsoft account.  See error message (image 1) below.

I login to sharepoint as an owner and I can see the members who were invited. See image 2. When I click on the members on the group, the icon spins and doesn't show a result.

So I do another test. I make a fake Microsoft account and invite this user to my Microsoft team - same error page results. I login to the Sharepoint site as this user and I can see the site, pages and members.

Again, I am using free teams.  Is anyone else experiencing this issue?

1122

Any help is appreciated.

Thanks for you time.

www.000webhost.com