Is your default web browser Chrome or Safari? If it is Safari, turn off the 'cross-web tracking' then try the link again, it should then prompt you to open the link in the app.

In Safari - Preferences > Privacy and uncheck the Prevent cross-site tracking setting.