best response confirmed by JimC_95 (Visitor)
Solution
Did you check the meeting policies and per-meeting settings? Open the Teams admin center > Meetings > Meeting settings > Anonymous users can join a meeting. Might want to also check the settings under Meeting policies > Global > Participants & Guests. On a per-meeting level, you can control whether Guests will be auto-admitted, can they present, etc.
www.000webhost.com