The non working touch keyboard

Frequent Contributor

Since the beginning of November the touch keyboard is broken in canary and dev.

This has been reported on this forum and also demonstrated for members of the Edge team onsite at Ignite.


So far it has not been fixed or even added to the public known bugs list.


To make it clearer I have recorded two small videos of it.

Canary is 81.0.363.0 and as you can see - clicking on the url bar does NOT bring up the touch keyboard

Beta is 79.0.309.47 and it does bring up the keyboard as it should


On a Surface this is a major usability issue

2 Replies



Hi, seems the guy from the Google Chromium Team finally fixed it: 


It's now live for testing on the latest Google Canary #81.0.3997.0 

Hope Edge Canary will update to the new chromium core soon.


Btw. I see from your screencast that you're too using the old/legacy keyboard (registry-key: "DisableNewKeyboardExperience"). With the fix the virtual keyboard now properly invokes on textfields in lastest Google Canary, but doesn't close when leaving or touching on an empty space.

But with the new virtual keybord it works. Can you please test and confirm?





Sorry, I'm only got a 1607 LTSB install on a sp4 currently and it doesn't have that regvalue.

The Chromium patch do work on that though.


Seems like it was a MS Employee that fixed it too.

Thanks to you for making the Surface usable again


Now we only have to wait to get it in canary and dev too