SOLVED

Playready DRM Windows 10

Occasional Contributor
Hi

My problem is 81.0.416.50 version Chromium Edge is not supporting 1080p videos on Netflix.  

 

PlayReady DRM for Windows 10 is enable on edge://flags

 

User agent selected as a Microsoft Edge Chromium Windows

 

All cookies and caches cleaned.

 

* There is no any flag as Playready Experimental Hevc decoding but yet i downloaded Hevc video extension (firstly tried without download and nothing changed)

 

**If widevine DRM disabled, netflix sending error code M7701-1003 which is saying that enable the Widevine.

 

 

Sorry for my english.

Thanks

41 Replies
Can't reproduce.
I have the same build as you and I don't face any issue in playing 1080p Netflix content, no flags set.
Might be worth giving a link to the content you are facing this issue with.
I tired with several contents. Pls stream a video and while on it, Cntrl+Alt+Shift and Press D. Let me know your resolution (playing bitrate)

@demircelikLtd 
I am aware of that shortcut and that is what I used to confirm my 1080p playback.
Also media is playing with avc1 encoder in Netflix for me. Haven't seen hevc in a while, be it COVID be it might be used only for 2K and 4K content or just my selection of movies and shows I watch.
I've now tested with both PlayReady DRM flag set to Default and Enabled, getting 720p only with the flag Disabled.
Also you can go to edge://components to check Widevine CDM. See if it has a normal status and if it's updated.
Ultimately you can test you browser's DRM support on this drm demo page by bitmovin , now on the page you'll get a report of the DRMs systems detected on your browser under the EME section.

First of all uninstalled chromium microsoft edge and then reboot the system. I just downloaded back the chromium browser and for check the DRM visited to https://bitmovin.com/demos/drm
There is writing that No DRM detected in both flag default and enabled.
Before download the Chromium Edge, i did test my IE based Edge browser with same way and there was writing that detected Playready DRM.

Is there any solution about this matter or way to follow?
*Widevine is up to date

I just checked this issue with another laptop which one is using clean windows 10, IExplorer based Microsoft Edge. 

 

On the first try with IE Based browser; DRM detected: PlayReady same as previous laptop then i downloaded the Chromium Edge and tested but this time detected No DRM. 

I am having same trouble with 2 different laptop. 

Both of them using 80.0.361.111 vers. Chromium Edge.

 

Is there any additional extension or something to install?

@demircelikLtd 


@demircelikLtd wrote:
*Widevine is up to date

 

is your OS also up to date?

Could you please explain OS?
Sure, OS stands for Operation System, like Windows.
if you're on Windows 10 you can go to the Settings => System = > About and see the "OS Build" info
Thanks.
OS build 18363.752
Great, it's up to date

Same issue, enabled PlayReady in flags and tried Media Foundation as well. Stable and Canary

 

https://html5test.com/ shows no support for H.265

https://bitmovin.com/demos/drm, shows no DRM in edge or Chrome, shows WideVine in FF 

Even the list of support MSE/EME is blank
`MediaSource.isTypeSupported('video/mp4; codecs="hvc1"')` is false

 

Could be this issue here? https://github.com/google/eme-encryption-scheme-polyfill/pull/14

But that PR was merged so it should be in Edge already.

As for bitmovin, I know it seems silly but have you guys tried to refresh the page a couple of times? I seem to need to from time to time in order for the MSE and EME to show and information.
Again, no issue with Netflix here though.

@Coddy 

 

Hi. 

Yes i did couple of times and nothing changed. Also easy to understand by not streaming videos on Netflix. Edge is not runnig Playready obviously so that Netflix streaming videos 720p with Widevine DRM. 

If disable the Widevine DRM flag when Playready is enable, getting error code F7701-1003.

 

@Coddy Windows 18363.773 seems to have enabled PlayReady support in Edge to be recognised and I'm now getting the HEVC codec in Netflix on Edge, can't seem to trigger 4k unlike the app, but is that a Netflix problem?

@unknown9595 Our team had a question for you: can you please confirm that your machine is configured to play H.265/HEVC content? This typically requires a specific extension from the Microsoft Store.

 

Fawkes (they/them)
Project & Community Manager - Microsoft Edge

@Coddy Our devs found it curious that you aren't getting 720p. If you haven't yet, can you please submit feedback and diagnostic data through the browser? (Shift + Alt + I ) This potentially seems like a separate issue.

 

Thanks!

 

Fawkes (they/them)
Project & Community Manager - Microsoft Edge

@demircelikLtd Thanks for reaching out! (And no worries, your English is great. :smile:)

 

Our product team generally tries to set the expectation that any feature behind a flag is still in development and may not yet work properly in all environments. However, they'd love to learn more about exactly what roadblock you're hitting. If you haven't yet, can you also please diagnostic data and detailed feedback through the browser? It really helps the team troubleshoot.

 

Fawkes (they/them)
Project & Community Manager - Microsoft Edge

@Deleted 
What do you mean by "found it curious that you(me) aren't getting 720p" ?
I'm getting the feeling some of my posts got misread. Allow me to clarify:
I do get 1080p resolution with the PlayReady flag Enabled and/or Default and I do get 720p when I set PlayReady flag to Disable, last I tested.

@Coddy Ah, thank you for the clarification! I will loop ask the team to reevaluate.

 

Fawkes (they/them)
Project & Community Manager - Microsoft Edge

www.000webhost.com