Outlook.com installed as PWA - calendar only opens in new tab

Contributor

I'm currently using Edge Version 97.0.1072.21 (Official build) beta (64-bit) on Linux Mint 20.1, and I have outlook.com installed as an Edge progressive web app. I have noticed an issue where clicking the calendar button in outlook.com will navigate to a new tab in Edge, and not display the calendar in the outllok.com PWA itself (the previous behavior). This is true for any other feature in outlook.com - People, Files, etc. Clicking any of the buttons below will just open Edge, or open a tab in an existing Edge instance:

 

mfcallahan_0-1638455220748.png

Is anyone else experiencing this?

5 Replies
Can confirm - experiencing the same, using Chrome on Red Hat Enterprise Linux 8. This seems like new behavior that came along at the same time as many styling changes in Outlook.
Found a WA on reddit in this thread, but have yet to confirm, Ctrl+Shift+1, Ctrl+Shift+2, etc.
Also I saw a mention of it stopping for one user:

https://www.reddit.com/r/Outlook/comments/r6bcx4/officeoutlookcom_links_always_opening_in_new_tab/

This appears to be fixed for me!

@mfcallahan 

 

This is not completely fixed. While clicking on any of the left side icons will switch from the mail PWA to whatever you clicked on, if you right-click on the icon, you only get the choice to open a new tab - same problem as previously described. Right-clicking used to open a full context menu that offered the choice to open the icon's functionality (i.e. calendar) as a separate PWA window. This way I could have both my mail and calendar as separate PWA windows. Now only one PWA window can be open at once while anything else will open in the edge browser - which is not a PWA. So its still broken - how could this get past QA?

www.000webhost.com