MS Edge kiosk mode offer to translate webpage

New Contributor

I have created a Microsoft Edge Kiosk mode based on the manual at: Configure Microsoft Edge kiosk mode | Microsoft Docs, using Windows Settings

I have previously used kiosk mode, both "Digital/Interactive Signage" and "Public-Browsing" with the old Edge, without problems.

Then I created a new Kiosk machine, based on Edge Chromium, an "Digital/Interactive Signage". It works well, except for it will always ask to set over the page from Norwegian to English! The page is a room plan for the building, updated regularly  at: TP: Timeplan (uio.no)

 

yvindSrbye_1-1641993096878.png

It's impossible to get rid of this message, it's popping up all the time.

Normally there is an option "Do not offer translation from Norwegian to English", but it's not there. If I translate from Norwegian to English, it has forgotten that choice next time the page is reloaded. 

If I choose "Not now", it's forgotten next time the page is reloaded.

If I accept Edge to set over from Norwegian to English, it does so, but the choice is forgotten next time the webpage is reloaded.

I also tried to set over from Norwegian to Norwegian, but at next refresh the choice was forgotten.

 

I have set up two computers with this kiosk configuration, one in Active Directory, one stand-alone, same result

 

The computer is Win10, Edge 97.0.1072.25

 

8 Replies

Hi,

Exact same thing here Windows 10 and Edge 97.0.1072.62.

Even if translation is disabled, in kiosk mode Edge is still asking for translating page !
Very annoying.

Glad to hear I am not the only one experiencing this. And yes, very annoying, this destroys a very good kiosk solution.

@Øyvind Sørbye 

 

I found a way to disable it add this option to command line : --disable-features=Translate 

 

Best regards,

 

Eric

@egdev 

 

Where do you put this command line in ?

@NikolejG 

 

Hi,

 

Unfortunately if you use Assigned Access I think you cannot put extra options.

But if you use shell:startup and a shortcut to run edge in the target of the shortcut you can put :

"C:\Program Files (x86)\Microsoft\Edge\Application\msedge.exe" --disable-features=Translate --no-first-run --kiosk <URL> --edge-kiosk-type=fullscreen

 

I found out of that

But i found also this article:
https://www.tenforums.com/tutorials/159502-turn-off-offer-translate-pages-microsoft-edge-chromium.ht...


That resolve the problem:
[HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Edge]
"TranslateEnabled"=dword:00000000

So thanks for this post and answers :)

Yes, modifying the Policies-key in registry is normally done with a Group Policy, and is a OK workaround! Still, I hope the Edge team could fix this bug.
Thank you so much it works even in assigned access. Cool !