MHT support for Outlook "view it in a web browser"

New Contributor

When viewing an email, Outlook sometimes displays an alert "If there are problems with how this message is displayed, click here to view it in a web browser".  Clicking the alert will open the email in Internet Explorer, even if another browser is selected as the default.  

 

Copying the URL from Internet Explorer into the new Edge address bar will display the raw HTML, but will not render the page.

 

file:///C:/Users/mseit/AppData/Local/Microsoft/Windows/INetCache/Content.Outlook/3HAGQHC9/email.mht

 

18 Replies

@SeitzM 

 

I tested this with the attached MHT file and I am seeing the same issue. I will be sure to bring this to the product team's attention.

Gabriel

@v-gapart  Has there been any updates?  I am working on a project at work using a google form to collect orders from our members.  The order is confirmed in an email automatically sent out to the member.  My issue arises here, the email from google is sent in MHTML format displaying their order, however the quantities they order look skewed.  It is viewable by clicking the "view in web browser") and then everything looks fine.  However I was curious if there is a way I can have it viewable within the email it's self every time.  If there were some instructions you can provide me to enable my outlook to view them properly within the outlook client.

 

I could understand if this is something I would need to do on the google side of the project, as its an email being sent from them.  However I don't believe that is an option at the moment..

@Awisnionski 

 

Is it possible to get the page sent as a standard html link rather than an MHTML file as that would undoubtedly directly open in the browser rather than asking if it should open in a browser?  Otherwise, you may want to contact the Microsoft Office team for Outlook to determine what settings would make the file automatically open in the browser rather than asking.  You can contact them at Support.office.com  

 

Gabriel

Hello, is there a status update to this annoying issue? Is an MS OUtlook update ready to be out yet, to upgrade this feature in line with email message hyperlinks? Kindly urge the team to do the needful at the earliest, as this was brought to attention almost 2 years back. Thanks, Rajiv

@SeitzM 

my customer has the same question. we going to use word as default application, instead of the iexplorer. 
But this feels more like an workarround, or what do you mean?

This is still a problem. Can't find anything to fix this.

I'm amazed this is still a thing. We've moved on from IE. We've also moved to the chromium version of Edge. Just let me view the preview in Edge!

@Pete_V_ 

 

@Microsoft Support 

 

Please update this bug, this seems like a gigantic security issue for outlook!!!  Not to mention super ridiculous that Internet Explorer is still a one and only handler for anything!

 

Make Edge support .mht files !!

Since a recent update, when you click the "view it in a web browser" Outlook is encouraging you to open the .mht in Edge ("New!"). Probably the MS marketing department ordered this :(
We would not need this "view it in a web browser" if Outlook would render HTML email properly. But it doesn't. In particular (nested) tables, typically used in newsletters are a nightmare. It used to be... well not really good but OK until Office 2007. Since then Outlook doesn't resize images in tables, it doesn't respect font styling in nested tables etc etc. Newsletters that look perfect in any email client can become unreadable in Outlook.
Please please make it so outlook can open these files in the browser properly.

@SeitzM 

I, too, am very annoyed at Outlook's refusal to load an MHTML link. Curiously, Microsoft's own "Mail" program included in Windows 10 handles MHTML links flawlessly. It doesn't even offer the "View in Browser" option but simply displays the link in Chrome, my default browser. Unfortunately, I'm an Outlook fan and do not have the motivation or time to figure out how to set up the kind of calendar function in "Mail" that I use multiple times each day in Outlook.

I have found a fix. In Edge, go to Settings, then Search for "compatibility". Under "Allow sites to be reloaded in Internet Explorer mode" choose "Allow". You will be prompted to restart Edge, Now the "View in browser" will open Edge and display correctly.
Thanks RonHinds!
@microsoft: you still have to fix this problem though! This is just a workaround for something that should work with default settings (or, should in fact not be required in the first place with Outlook properly rendering mhtml).
3 years later, this is still a problem

@P_____20Well, something has changed. Since half a year or so it opens in Edge in "Internet Explorer mode" without asking. Other browsers don't support .mht AFAIK.

But of course this is a typical Microsoft pins and needles - stopgap solution. The real problem is the bad HTML email rendering in Outlook. A newsletter that looks good in in any email client can become a mess in Outlook.

@DoveFromAbovethanks for the update info. It must be my enterprise version of Edge that is not handling MHT correct (still looks like source code). I agree that Outlook needs to be updated to handle modern HTML emails.

@P_____20 You may need to turn on the IE mode in Edge before it will work correctly. Search for Internet Explore in Edge settings, there are a few different settings you'll need to make.

@RonHinds - Yes, that works for my browser. The problem is trying to communicate those steps out to the 100k+ people who get these emails in their Outlook inbox.
www.000webhost.com