Dev channel update to 97.0.1060.2 is live

Microsoft

Hello Insiders!  Today we’re releasing build 97.0.1060.2 to the Dev channel, and it’s a big one!  Besides this being the first release for version 97, which means Beta is now at 96, we’ve got lots of other exciting community news: 

 

 

For everything that’s noteworthy in the product: 

 

Added features: 

 

  • Added the ability to draw arbitrary highlighting on PDFs. 
  • Added an option to print even or odd pages. 
  • Combined autofill and password generation on account sign-up webpages to be able to create new website accounts in a single click. 
  • Combined personal info and payment info autofill on certain shopping websites to be able to apply coupons and checkout in a single click. 
  • Enabled by default one-click password updating by adding a button to the leaked passwords Settings page that goes directly to the website’s password update page and then using password generation to automatically fill in a new password. 
  • Added the Downloads button to windows opened with the --app command line flag. 
  • Management policies (updates to documentation and administrative templates may not have occurred yet): 
    • Added a policy to control if the Internet Explorer Mode Toolbar Button is Enabled. 
    • Added a policy to control if the ability for Edge to automatically Enhance Images is Enabled. 
    • Added a policy to control if Accessibility Image Labels are Enabled, which controls if a service can be used to generate descriptions for images that don’t already have them. 
  • Developer: 
    • Added an experimental WebView2 API to handle basic website authentication (Issue 120). 
    • Added an experimental API to WebView2 apps to send and receive post web messages to iframes (Issue 139). 
    • Added an API to WebView2 apps to query the user data folder location. 

 

Improved reliability: 

 

  • Fixed a crash on launch on Linux. 
  • Fixed a crash on Mac when clicking the … button. 
  • Fixed a crash on Mac when updating the browser. 
  • Fixed a crash when closing the browser. 
  • Fixed a crash when closing certain popups. 
  • Fixed a crash when searching for text in a PDF. 
  • Fixed a crash when using video capture. 
  • Fixed a Web Widget crash when switching profiles. 
  • Mobile: 
    • Fixed a crash when typing in the address bar. 
    • Fixed an issue where closing the browser and then immediately re-opening it will crash it. 
    • Fixed a crash when sending a tab to another device. 
    • Fixed a crash when viewing certain Settings pages. 
    • Fixed a hang when navigating on iOS when using a VPN. 
  • Fixed a hang when navigating in IE mode tabs. 
  • Fixed a hang in Kids Mode when installing a theme. 
  • Fixed an issue where background processes were crashing frequently, leading to high CPU use. 
  • Developer: 
    • Fixed a crash in WebView2 apps when using certain management policies (Issue 1860). 
    • Fixed a crash in WebView2 apps after downloading a file (Issue 1723, Issue 1765). 

 

Changed behavior: 

 

  • Renamed Web Widget to Edge Bar. 
  • Changed the keyboard shortcut to open a new Application Guard window. 
  • Reduced the number of alerts that the browser is out of date for work/school users whose browser (and therefore updates) is managed by their organization.
  • Reduced the number of sites that get upgraded to HTTPS when Automatic HTTPS is enabled that shouldn’t be, such as intranet sites. 
  • Fixed an issue where Automatic HTTPS can sometimes cause navigations to hang if the website forcibly navigates back to an HTTP page. 
  • Fixed an issue where PDF layout is remembered between print jobs when it shouldn’t be, causing the default print layout to be incorrect for the page layout of the current PDF. 
  • Fixed an issue where PDFs with both portrait and landscape pages don’t print properly because all pages are forced into a single layout. 
  • Fixed an issue where the browser constantly steals focus from other apps. 
  • Fixed an issue where attempting to show the original text after translation of text on a webpage sometimes fails. 
  • Fixed an issue where dragging and dropping files into webpages in order to upload them fails. 
  • Fixed an issue where the mini context menus appear on websites they shouldn’t because those websites have their own menus that appear upon text selection. 
  • Fixed an issue where context menus don’t appear when triggered by touching a touchscreen. 
  • Fixed an issue where the vertical tabs pane scrolls slower with big turns of the mouse wheel than with small ones. 
  • Fixed an issue where bulk deletion of passwords in the password Settings page doesn’t respect the current page filter. 
  • Fixed an issue where pinned side panes appear on top of fullscreen webpages. 
  • Fixed an issue where double-clicking a word to select it sometimes doesn’t work. 
  • Fixed an issue where Smart Copy sometimes results in certain data being copied twice. 
  • Fixed an issue where searches sometimes fail when using Family Safety. 
  • Fixed an issue where a dialog to choose an app to handle certain links unexpectedly appears. 
  • Fixed an issue where certain UI is hard to see or mis-colored if custom themes are installed. 
  • Fixed an issue where the user’s profile picture doesn’t load when signing into the browser. 
  • Mobile: 
    • Fixed an issue where the setting to choose if links can launch external applications is missing. 
    • Fixed an issue where location permissions for webpages are prompted for more frequently than expected. 
    • Fixed an issue where Guided Switch sometimes doesn’t work. 
    • Fixed an issue where certain internal sites can’t be logged into for work/school users. 
    • Fixed an issue where downloads sometimes fail. 
    • Fixed an issue on iOS where certain files fail to download. 
    • Fixed an issue on Android where work or school accounts sometimes can’t be accessed and instead ask to sign into the browser even though the user already is. 
  • Developer: 
    • Fixed an issue where WebView2 apps don’t work properly when the main view isn’t created by StartupUri (Issue 1577). 
    • Fixed an exception in .NET-based WebView2 apps (Issue 946). 

 

Known issues: 

 

  • Users of certain ad blocking extensions may experience playback errors on YouTube.  As a workaround, temporarily disabling the extension should allow playback to proceed.  See this help article for more details. 
  • Some users are still running into an issue where all tabs and extensions immediately crash with a STATUS_INVALID_IMAGE_HASH error.  The most common cause of this error is outdated security or antivirus software from vendors like Symantec, and in those cases, updating that software will fix it. 
  • Users of the Kaspersky Internet Suite who have the associated extension installed may sometimes see webpages like Gmail fail to load.  This failure is due to the main Kaspersky software being out of date, and is thus fixed by making sure the latest version is installed. 
  • Some users are seeing “wobbling” behavior when scrolling using trackpad gestures or touchscreens, where scrolling in one dimension also causes the page to subtly scroll back and forth in the other.  Note that this only affects certain websites and seems to be worse on certain devices.  This is most likely related to our ongoing work to bring scrolling back to parity with Edge Legacy’s behavior, so if this behavior is undesirable, you can temporarily turn it off by disabling the edge://flags/#edge-experimental-scrolling flag. 

 

Stable users, make sure you also have been updated to version 95, it’s been out for a while now! 

29 Replies
Thank you for adding never show extensions button option!

@josh_bodner 

The issue I reported has been fixed.
Thanks!!

Print Preview dialog box doesn't show Preview and doesn't work. I must print using Ctrl-Shift-P sequence only on ALL printers including PDF printers. This has happened after this latest update on three of my PCs.

Same issue here: Print Preview does not work.

Yeah agreed. Print preview has gone on holiday it seems, connection is lost.
In the Feedback channel, there's no way to upvote someone's comment.
Not only does print preview not work, but I can't get a page to print at all. This is really bad for people that use the Dev channel all the time.
What? Where?

So, since printing does not work any more in this version, we'll have to wait for a fix.
In the meantime, we'll have to temporarily use another version of Edge (standard, beta or canary version). So, is there an easy way to have all Settings, Favorites and Extensions (including their settings) of Edge Dev to be transferred to for example Edge Stable (as that version is also installed on our pc)?

Printing in Canary doesn't work if you are using forced dark mode, but you can easily turn that flag off.
Not able to print in latest Dev Version.
Have you tried pressing Ctrl-Shift-P (all 3 together) to bring up the regular Windows Print dialogue box?
Try pressing (all at once) Ctrl+Shift+P to bring up the normal Windows Print dialogue box.

@josh_bodner Translation also doesn't appear to work in this version for me.  Clicking on a link like Alarmstimmung: VW-Chefs wollen Stammwerk radikal umbauen - Business Insider no longer offers to translate from german (in this case) to english.

@jhajin and anybody else seeing this, can you check in Canary?  It appears to be fixed in Canary, in which case it should also be fixed in next week's Dev.  

@Paul_VC Sync will pick up a lot of that, although there are certain settings that don't sync yet.  

Is it just the address bar popup that's not appearing, or is translate not working at all? Can you get it to translate via the right-click menu?

@josh_bodner For me, it's not auto popping up in the address bar or offering to translate automatically as it does in the production version of Edge.

 

Here is a snippet of the area where it would appear and no translation icon in dev (I don't have canary loaded):

MichaelJones_0-1636058690844.png

Here is production:

MichaelJones_1-1636058774404.png

 

It does appear to work in dev from the right-click context menu, however.  And when I do that the icon reappears in the address bar.

 

Maybe someone else can try and make sure it's not just me.

 

I don't have access to Canary, but I suspect you're right about next week's build having fixed this. It happened about a year ago and was fixed in the next build.
www.000webhost.com