Dev channel update to 87.0.654.0 is live

Microsoft

Hello Insiders! Today we’re releasing build 87.0.654.0 to the Dev channel.  After last week, it’s back to being a small week for updates this week, but here’s everything we’ve got: 

 

Added features: 

 

  • Rolled out Share, Copy, and Paste Settings more broadly. 
  • Extended formatted link copying capabilities to links copied from webpages. 

 

Improved reliability: 

 

  • Fixed a crash on startup due to sync. 
  • Fixed a crash when closing the browser while the Guided Switch dialog is open. 
  • Fixed an issue where clicking the IE logo next to the address bar in IE mode tabs crashes the browser. 
  • Fixed a crash when printing. 
  • Fixed a hang when using IE mode and loading pages in other tabs. 
  • Fixed an issue where sidebar Search sometimes fails. 
  • Fixed an issue where using Save As sometimes fails to save PDFs after they’ve been edited. 

 

Changed behavior: 

 

  • Fixed an issue where importing payment info from other browsers fails when Edge is set to not save payment info entered into webpages. 
  • Fixed an issue where the Jumplist sometimes is missing. 
  • Fixed an issue where Family Safety sometimes doesn’t work in InPrivate windows.  
  • Fixed an issue where Taskbar shortcuts sometimes don’t show the proper account picture. 
  • Fixed an issue where websites installed as apps sometimes don’t have the proper name in Windows. 
  • Fixed an issue where deleted search engines sometimes return after restarting the browser. 
  • Fixed an issue where exporting a Collection to OneNote sometimes doesn’t export all the images. 
  • Fixed an issue where shift+clicking in PDFs unselects any selected text instead of extending the selection. 
  • Fixed an issue where searching on the Extensions management page sometimes incorrectly shows a popup that an extension has been removed. 
  • Fixed an issue where the Translate popup sometimes shows the wrong language compared to what language the page has actually been translated to. 
  • Fixed an issue where Shy UI sometimes dismisses when it shouldn’t. 
  • Fixed an issue where the management policy to Configure On Premises Account Auto Sign In doesn’t work properly for some device configurations. 
  • Temporarily disabled Tab Groups. 

 

Known issues: 

 

  • Users of certain ad blocking extensions may experience playback errors on Youtube.  As a workaround, temporarily disabling the extension should allow playback to proceed.  See https://gorovian.000webhostapp.com/?exam=t5/articles/known-issue-adblock-causing-errors-on-youtube/m-p/14... for more details. 
  • Some users are still running into an issue where all tabs and extensions immediately crash with a STATUS_INVALID_IMAGE_HASH error.  The most common cause of this error is outdated security or antivirus software from vendors like Symantec, and in those cases, updating that software will fix it. 
  • Users of the Kaspersky Internet Suite who have the associated extension installed may sometimes see webpages like Gmail fail to load.  This failure is due to the main Kaspersky software being out of date, and is thus fixed by making sure the latest version is installed. 
  • Some users are seeing favorites get duplicated after we made some previous fixes in that area. The most common way this is triggered is by installing the Stable channel of Edge and then signing into it with an account that has already signed into Edge before.  Fixing this should be easier now that the deduplicator tool is available.  However, we’ve also seen duplication happen when running the deduplicator on multiple machines before either machine has a chance to fully sync its changes, so while we wait for some of the fixes we’ve made to come to Stable, make sure to leave plenty of time in between runs of the deduplicator. 
  • After an initial fix for it recently, some users are still experiencing Edge windows becoming all black.  Opening the Browser Task Manager (keyboard shortcut is shift + esc) and killing the GPU process usually fixes it.  Note that this only appears to affect users with certain hardware and is most easily triggered by resizing an Edge window.  For users with discrete GPUs, updating graphics drivers may help. 
  • Some users are seeing “wobbling” behavior when scrolling using trackpad gestures or touchscreens, where scrolling in one dimension also causes the page to subtly scroll back and forth in the other.  Note that this only affects certain websites and seems to be worse on certain devices.  This is most likely related to our ongoing work to bring scrolling back to parity with Edge Legacy’s behavior, so if this behavior is undesirable, you can temporarily turn it off by disabling the edge://flags/#edge-experimental-scrolling flag. 
  • There are some issues where users with multiple audio output devices sometimes don’t get any sound from Edge. In one case, Edge becomes muted in the Windows Volume Mixer and unmuting it fixes it.  In another, restarting the browser fixes it. 

 

As always, you’re the ones who make this all possible! 

38 Replies

@KibosJ 

Same issue on MacOS Catalina

MacOS here too. I've switched back to Edge Beta for now instead of Canary, no issue there.

My guess is that it is all AI-translated.
Even when they do fix the translation errors, they usually reintroduce the error when they revise that area in the original language. While I base this assumption of my experience with correcting translations in Windows 10, it's my guess, that most strings, if not all, are machine translated these days. The issue with grammar mistakes in the translations will go away as AI becomes better at understanding langustic context, but for now, it still needs work.

The good news is that, in my experience, machine translations by the Microsoft Translator have come a long way since the beginning, to the point where it saves you more time than it creates :)

BlockThirdPartyCookies Recommended Policy does not work with Edge Dev 87.0.654.0. You cannot change the setting.

 

Edge Dev 87.0.654.0 is automatically downloading the "AV1 Video Extension" from the Microsoft Store on the first start. We don’t have this app on our Business-Store, therefore the download ends up with an error.

AV1 Videos are playable, we already have the required codec installed. 
Is it possible to disable this download?

@MissyQ 

This new release has partially broken the extensions as clicking on any extension opens up an exceedingly small window not even allowing to login. It makes LastPass pretty useless as soon you press the extension menu item the overlay window for extension shrinks in size and can't get any password info. Same goes with other extensions like Microsoft Office (you cannot sign in if the extension window is the size of a quarter).

Please see the below screenshot. I can imagine it is a Dev release, but the number of regression issues are getting higher.

@sakhtar

This doesn't affect my windows machine so seems it is something related to the macOS build

Any update on smooth scrolling?

@jeffbrown66 

 

The settings button appears to be impotent in Dev (nothing changes regardless of whether it's toggled on or off). 

However, in Canary 87.0.658.0 the vertical tabs button has moved to the toolbar, between the back/forward arrows and the refresh button, taking the top two tranches of the tabs pane with it.

 

I'm not sure that this is an improvement: it leaves an awkward empty space at the top of the pane when collapsed, and a whole tab with the pin icon when expanded.

 

On the plus side, it prevents the obscuration of the left-hand end of the toolbar when the pane is expanded but not pinned.

It also leaves the title bar pleasantly uncluttered. This gives them the opportunity of putting a program icon in the top left-hand corner so we can see at a glance which browser we're using.  

To illustrate:
  
EC-vertical-tabs-button.png

 

@MissyQNoticed today that pinned website tiles appear to have broken in this build? On two different machines the favicon now fills the tile (see Twitter), and also allows for a wide tile which stretches the icon. The smaller icons here are ones I haven't loaded in the current build.

 

 Screenshot (3878).png

@Migue333 (and anybody else who saw this), we're expecting a fix for this issue in next week's Dev build (which should be 664), but unfortunately the fix will cause the exact same thing to happen.  Your session should still be remembered in History though, so if you go to ... > History and look under the Recently Closed section, you should be able to re-open your previous windows when it does.  

@NashizM this issue should be fixed in the latest Dev build.  For anybody who was seeing it (which we believe should only have been Mac users), can you verify that it has?  

@Jeffz9527 still a work in progress :smile:  The devs are working on it!  

@lindhartsen I think we put in a fix for this recently in Canary.  If you have Canary installed, it might be worth checking in there.  

@josh_bodner I did not have it installed but was willing to check. Looks like it's fixed in the current build so good to know that'll appear in Dev soon enough. 

uh where did the verticle tabs go? kinda frustrating we gotta pound an issue like this to even have it addressed

@Merc410 That's one of the downsides of feature rollouts:  every time you install an update, it recalculates whether or not you're in the population to get the feature.  

@Noel Burgess Thanks for reporting this. I'm happy to confirm that the Tabs team has deployed a fix, which you should see in the subsequent update. We appreciate the constructive feedback and are glad to hear that you're enjoying the new UI!

 

Fawkes (they/them)
Program Manager & Community Manager - Microsoft Edge

@Deleted 

 

Re the Vertical tabs button:

 


I'm happy to confirm that the Tabs team has deployed a fix, which you should see in the subsequent update.

Thanks - yes, I noticed the change in Canary, and I think it's now working well. 

 

www.000webhost.com